summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mismatching-target-triples
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/mismatching-target-triples
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/mismatching-target-triples')
-rw-r--r--tests/run-make/mismatching-target-triples/Makefile11
-rw-r--r--tests/run-make/mismatching-target-triples/bar.rs3
-rw-r--r--tests/run-make/mismatching-target-triples/foo.rs3
3 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/mismatching-target-triples/Makefile b/tests/run-make/mismatching-target-triples/Makefile
new file mode 100644
index 000000000..409388e04
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Issue #10814
+#
+# these are no_std to avoid having to have the standard library or any
+# linkers/assemblers for the relevant platform
+
+all:
+ $(RUSTC) foo.rs --target=i686-unknown-linux-gnu
+ $(RUSTC) bar.rs --target=x86_64-unknown-linux-gnu 2>&1 \
+ | $(CGREP) 'couldn'"'"'t find crate `foo` with expected target triple x86_64-unknown-linux-gnu'
diff --git a/tests/run-make/mismatching-target-triples/bar.rs b/tests/run-make/mismatching-target-triples/bar.rs
new file mode 100644
index 000000000..b2c2fc1c4
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/bar.rs
@@ -0,0 +1,3 @@
+#![feature(no_core)]
+#![no_core]
+extern crate foo;
diff --git a/tests/run-make/mismatching-target-triples/foo.rs b/tests/run-make/mismatching-target-triples/foo.rs
new file mode 100644
index 000000000..6fa054914
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/foo.rs
@@ -0,0 +1,3 @@
+#![feature(no_core)]
+#![no_core]
+#![crate_type = "lib"]