summaryrefslogtreecommitdiffstats
path: root/tests/run-make/output-filename-conflicts-with-directory
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/output-filename-conflicts-with-directory
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/output-filename-conflicts-with-directory')
-rw-r--r--tests/run-make/output-filename-conflicts-with-directory/Makefile7
-rw-r--r--tests/run-make/output-filename-conflicts-with-directory/foo.rs1
2 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/output-filename-conflicts-with-directory/Makefile b/tests/run-make/output-filename-conflicts-with-directory/Makefile
new file mode 100644
index 000000000..45221356c
--- /dev/null
+++ b/tests/run-make/output-filename-conflicts-with-directory/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo.rs
+ mkdir $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the generated executable for the input file \".*foo\.rs\" conflicts with the existing directory \".*foo\""
diff --git a/tests/run-make/output-filename-conflicts-with-directory/foo.rs b/tests/run-make/output-filename-conflicts-with-directory/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make/output-filename-conflicts-with-directory/foo.rs
@@ -0,0 +1 @@
+fn main() {}