summaryrefslogtreecommitdiffstats
path: root/tests/run-make/print-target-list
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/print-target-list
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/print-target-list')
-rw-r--r--tests/run-make/print-target-list/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/print-target-list/Makefile b/tests/run-make/print-target-list/Makefile
new file mode 100644
index 000000000..f23c40d42
--- /dev/null
+++ b/tests/run-make/print-target-list/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+# Checks that all the targets returned by `rustc --print target-list` are valid
+# target specifications
+all:
+ for target in $(shell $(BARE_RUSTC) --print target-list); do \
+ $(BARE_RUSTC) --target $$target --print sysroot; \
+ done