summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prune-link-args/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/prune-link-args/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/prune-link-args/Makefile')
-rw-r--r--tests/run-make/prune-link-args/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/prune-link-args/Makefile b/tests/run-make/prune-link-args/Makefile
new file mode 100644
index 000000000..c21ba6ace
--- /dev/null
+++ b/tests/run-make/prune-link-args/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+# Notice the space in the end, this emulates the output of pkg-config
+RUSTC_FLAGS = -C link-args="-lc "
+
+all:
+ $(RUSTC) $(RUSTC_FLAGS) empty.rs