summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prune-link-args/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/prune-link-args/Makefile')
-rw-r--r--tests/run-make/prune-link-args/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/prune-link-args/Makefile b/tests/run-make/prune-link-args/Makefile
new file mode 100644
index 000000000..c21ba6ace
--- /dev/null
+++ b/tests/run-make/prune-link-args/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+# Notice the space in the end, this emulates the output of pkg-config
+RUSTC_FLAGS = -C link-args="-lc "
+
+all:
+ $(RUSTC) $(RUSTC_FLAGS) empty.rs