summaryrefslogtreecommitdiffstats
path: root/vendor/always-assert
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/always-assert
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/always-assert')
-rw-r--r--vendor/always-assert/.cargo-checksum.json2
-rw-r--r--vendor/always-assert/Cargo.toml19
-rw-r--r--vendor/always-assert/src/lib.rs1
3 files changed, 14 insertions, 8 deletions
diff --git a/vendor/always-assert/.cargo-checksum.json b/vendor/always-assert/.cargo-checksum.json
index 6f93ea378..72faec339 100644
--- a/vendor/always-assert/.cargo-checksum.json
+++ b/vendor/always-assert/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"c08f962d99127c844ab8f03886adaff10962915cb3c0b2790ee4d331bc809e33","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"fd6b76a4d4af25f7d39d1b0452f3779fccf66bf4a75787129a531ef2f32be593","src/lib.rs":"552e51ffa1be8614717111dd97cdafdfbfb195131373e6d4c9f2698453e782ba","tests/it.rs":"60f4b22d8c8e84db2ad6cd9f58106c9103a4d0ea3dde7dfa3657afad9c04bf8d"},"package":"fbf688625d06217d5b1bb0ea9d9c44a1635fd0ee3534466388d18203174f4d11"} \ No newline at end of file
+{"files":{"Cargo.toml":"4a168f2760d6272f12c5d58cd93c0cbcd7d767820a3f6048ad84a35b88aa4bec","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"fd6b76a4d4af25f7d39d1b0452f3779fccf66bf4a75787129a531ef2f32be593","src/lib.rs":"69b91432a874c89b6ccc8a1ef9d8969dd389b7ae7f81727068207172d377941e","tests/it.rs":"60f4b22d8c8e84db2ad6cd9f58106c9103a4d0ea3dde7dfa3657afad9c04bf8d"},"package":"4436e0292ab1bb631b42973c61205e704475fe8126af845c8d923c0996328127"} \ No newline at end of file
diff --git a/vendor/always-assert/Cargo.toml b/vendor/always-assert/Cargo.toml
index 74efd7517..0b05a414a 100644
--- a/vendor/always-assert/Cargo.toml
+++ b/vendor/always-assert/Cargo.toml
@@ -3,24 +3,29 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "always-assert"
-version = "0.1.2"
+version = "0.1.3"
authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
-exclude = [".github/", "bors.toml", "rustfmt.toml"]
+exclude = [
+ ".github/",
+ "bors.toml",
+ "rustfmt.toml",
+]
description = "Recoverable assertions for long-running robust applications"
+readme = "README.md"
keywords = ["assert"]
categories = ["development-tools::debugging"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/matklad/always-assert"
+
[dependencies.log]
version = "0.4"
optional = true
diff --git a/vendor/always-assert/src/lib.rs b/vendor/always-assert/src/lib.rs
index 4cb8653b3..412056d94 100644
--- a/vendor/always-assert/src/lib.rs
+++ b/vendor/always-assert/src/lib.rs
@@ -1,3 +1,4 @@
+#![no_std]
//! Recoverable assertions, inspired by [the use of `assert()` in
//! SQLite](https://www.sqlite.org/assert.html).
//!