summaryrefslogtreecommitdiffstats
path: root/vendor/console/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/console/Makefile
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/console/Makefile')
-rw-r--r--vendor/console/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/console/Makefile b/vendor/console/Makefile
new file mode 100644
index 000000000..ccab99dd7
--- /dev/null
+++ b/vendor/console/Makefile
@@ -0,0 +1,39 @@
+all: test
+
+check:
+ @cargo check --all-features
+
+build:
+ @cargo build --all-features
+
+doc:
+ @cargo doc --all-features
+
+test:
+ @echo "CARGO TESTS"
+ @cargo test
+ @cargo test --all-features
+ @cargo test --no-default-features
+
+check-minver:
+ @echo "MINVER CHECK"
+ @cargo minimal-versions check
+ @cargo minimal-versions check --all-features
+ @cargo minimal-versions check --no-default-features
+
+format:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all
+
+format-check:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all -- --check
+
+lint:
+ @rustup component add clippy 2> /dev/null
+ @cargo clippy --examples --tests
+
+msrv-lock:
+ @cargo update -p proptest --precise=1.0.0
+
+.PHONY: all doc build check test format format-check lint check-minver msrv-lock