summaryrefslogtreecommitdiffstats
path: root/vendor/console/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/console/Makefile')
-rw-r--r--vendor/console/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/console/Makefile b/vendor/console/Makefile
new file mode 100644
index 000000000..ccab99dd7
--- /dev/null
+++ b/vendor/console/Makefile
@@ -0,0 +1,39 @@
+all: test
+
+check:
+ @cargo check --all-features
+
+build:
+ @cargo build --all-features
+
+doc:
+ @cargo doc --all-features
+
+test:
+ @echo "CARGO TESTS"
+ @cargo test
+ @cargo test --all-features
+ @cargo test --no-default-features
+
+check-minver:
+ @echo "MINVER CHECK"
+ @cargo minimal-versions check
+ @cargo minimal-versions check --all-features
+ @cargo minimal-versions check --no-default-features
+
+format:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all
+
+format-check:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all -- --check
+
+lint:
+ @rustup component add clippy 2> /dev/null
+ @cargo clippy --examples --tests
+
+msrv-lock:
+ @cargo update -p proptest --precise=1.0.0
+
+.PHONY: all doc build check test format format-check lint check-minver msrv-lock