summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/ci/run-docker.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/libz-sys/ci/run-docker.sh
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libz-sys/ci/run-docker.sh')
-rwxr-xr-xvendor/libz-sys/ci/run-docker.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/vendor/libz-sys/ci/run-docker.sh b/vendor/libz-sys/ci/run-docker.sh
new file mode 100755
index 000000000..73a0847d5
--- /dev/null
+++ b/vendor/libz-sys/ci/run-docker.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+set -ex
+
+mkdir -p target
+
+docker build --rm -t libz-sys-ci ci
+docker run \
+ --rm \
+ --init \
+ --user $(id -u):$(id -g) \
+ --volume `rustc --print sysroot`:/usr/local:ro \
+ --volume `pwd`:/src:ro \
+ --volume `pwd`/target:/src/target \
+ --workdir /src \
+ --env CARGO_HOME=/cargo \
+ --volume $HOME/.cargo:/cargo \
+ -it \
+ libz-sys-ci \
+ cargo run --manifest-path systest/Cargo.toml -vv