summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/ci/run-docker.sh
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/libz-sys/ci/run-docker.sh')
-rwxr-xr-xvendor/libz-sys/ci/run-docker.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/vendor/libz-sys/ci/run-docker.sh b/vendor/libz-sys/ci/run-docker.sh
new file mode 100755
index 000000000..73a0847d5
--- /dev/null
+++ b/vendor/libz-sys/ci/run-docker.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+set -ex
+
+mkdir -p target
+
+docker build --rm -t libz-sys-ci ci
+docker run \
+ --rm \
+ --init \
+ --user $(id -u):$(id -g) \
+ --volume `rustc --print sysroot`:/usr/local:ro \
+ --volume `pwd`:/src:ro \
+ --volume `pwd`/target:/src/target \
+ --workdir /src \
+ --env CARGO_HOME=/cargo \
+ --volume $HOME/.cargo:/cargo \
+ -it \
+ libz-sys-ci \
+ cargo run --manifest-path systest/Cargo.toml -vv