summaryrefslogtreecommitdiffstats
path: root/vendor/string_cache_codegen
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/string_cache_codegen
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/string_cache_codegen')
-rw-r--r--vendor/string_cache_codegen/.cargo-checksum.json1
-rw-r--r--vendor/string_cache_codegen/Cargo.toml35
-rw-r--r--vendor/string_cache_codegen/LICENSE-APACHE201
-rw-r--r--vendor/string_cache_codegen/LICENSE-MIT25
-rw-r--r--vendor/string_cache_codegen/lib.rs286
5 files changed, 548 insertions, 0 deletions
diff --git a/vendor/string_cache_codegen/.cargo-checksum.json b/vendor/string_cache_codegen/.cargo-checksum.json
new file mode 100644
index 000000000..8e2c50d53
--- /dev/null
+++ b/vendor/string_cache_codegen/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"7f8b4466da00825b1b13d102f8de7007f34684d0a74de0cb5bdc55a7eefe3144","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"62065228e42caebca7e7d7db1204cbb867033de5982ca4009928915e4095f3a3","lib.rs":"052b190a00c871e3ec62ed15b31e2fc7322e950a6de434018840389b97054a72"},"package":"6bb30289b722be4ff74a408c3cc27edeaad656e06cb1fe8fa9231fa59c728988"} \ No newline at end of file
diff --git a/vendor/string_cache_codegen/Cargo.toml b/vendor/string_cache_codegen/Cargo.toml
new file mode 100644
index 000000000..f688706a2
--- /dev/null
+++ b/vendor/string_cache_codegen/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "string_cache_codegen"
+version = "0.5.2"
+authors = ["The Servo Project Developers"]
+description = "A codegen library for string-cache, developed as part of the Servo project."
+documentation = "https://docs.rs/string_cache_codegen/"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/string-cache"
+
+[lib]
+name = "string_cache_codegen"
+path = "lib.rs"
+[dependencies.phf_generator]
+version = "0.10"
+
+[dependencies.phf_shared]
+version = "0.10"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
diff --git a/vendor/string_cache_codegen/LICENSE-APACHE b/vendor/string_cache_codegen/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/string_cache_codegen/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/string_cache_codegen/LICENSE-MIT b/vendor/string_cache_codegen/LICENSE-MIT
new file mode 100644
index 000000000..807526f57
--- /dev/null
+++ b/vendor/string_cache_codegen/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2012-2013 Mozilla Foundation
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/string_cache_codegen/lib.rs b/vendor/string_cache_codegen/lib.rs
new file mode 100644
index 000000000..0fe4819ef
--- /dev/null
+++ b/vendor/string_cache_codegen/lib.rs
@@ -0,0 +1,286 @@
+// Copyright 2016 The Servo Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+//! A crate to create static string caches at compiletime.
+//!
+//! # Examples
+//!
+//! With static atoms:
+//!
+//! In `Cargo.toml`:
+//!
+//! ```toml
+//! [package]
+//! build = "build.rs"
+//!
+//! [dependencies]
+//! string_cache = "0.8"
+//!
+//! [build-dependencies]
+//! string_cache_codegen = "0.5"
+//! ```
+//!
+//! In `build.rs`:
+//!
+//! ```no_run
+//! extern crate string_cache_codegen;
+//!
+//! use std::env;
+//! use std::path::Path;
+//!
+//! fn main() {
+//! string_cache_codegen::AtomType::new("foo::FooAtom", "foo_atom!")
+//! .atoms(&["foo", "bar"])
+//! .write_to_file(&Path::new(&env::var("OUT_DIR").unwrap()).join("foo_atom.rs"))
+//! .unwrap()
+//! }
+//! ```
+//!
+//! In `lib.rs`:
+//!
+//! ```ignore
+//! extern crate string_cache;
+//!
+//! mod foo {
+//! include!(concat!(env!("OUT_DIR"), "/foo_atom.rs"));
+//! }
+//! ```
+//!
+//! The generated code will define a `FooAtom` type and a `foo_atom!` macro.
+//! The macro can be used in expression or patterns, with strings listed in `build.rs`.
+//! For example:
+//!
+//! ```ignore
+//! fn compute_something(input: &foo::FooAtom) -> u32 {
+//! match *input {
+//! foo_atom!("foo") => 1,
+//! foo_atom!("bar") => 2,
+//! _ => 3,
+//! }
+//! }
+//! ```
+//!
+
+#![recursion_limit = "128"]
+
+use quote::quote;
+use std::collections::HashSet;
+use std::fs::File;
+use std::io::{self, BufWriter, Write};
+use std::path::Path;
+
+/// A builder for a static atom set and relevant macros
+pub struct AtomType {
+ path: String,
+ atom_doc: Option<String>,
+ static_set_doc: Option<String>,
+ macro_name: String,
+ macro_doc: Option<String>,
+ atoms: HashSet<String>,
+}
+
+impl AtomType {
+ /// Constructs a new static atom set builder
+ ///
+ /// `path` is a path within a crate of the atom type that will be created.
+ /// e.g. `"FooAtom"` at the crate root or `"foo::Atom"` if the generated code
+ /// is included in a `foo` module.
+ ///
+ /// `macro_name` must end with `!`.
+ ///
+ /// For example, `AtomType::new("foo::FooAtom", "foo_atom!")` will generate:
+ ///
+ /// ```ignore
+ /// pub type FooAtom = ::string_cache::Atom<FooAtomStaticSet>;
+ /// pub struct FooAtomStaticSet;
+ /// impl ::string_cache::StaticAtomSet for FooAtomStaticSet {
+ /// // ...
+ /// }
+ /// #[macro_export]
+ /// macro_rules foo_atom {
+ /// // Expands to: $crate::foo::FooAtom { … }
+ /// }
+ /// ```
+ pub fn new(path: &str, macro_name: &str) -> Self {
+ assert!(macro_name.ends_with("!"), "`macro_name` must end with '!'");
+ AtomType {
+ path: path.to_owned(),
+ macro_name: macro_name[..macro_name.len() - "!".len()].to_owned(),
+ atom_doc: None,
+ static_set_doc: None,
+ macro_doc: None,
+ atoms: HashSet::new(),
+ }
+ }
+
+ /// Add some documentation to the generated Atom type alias.
+ ///
+ /// This can help the user know that the type uses interned strings.
+ ///
+ /// Note that `docs` should not contain the `///` at the front of normal docs.
+ pub fn with_atom_doc(&mut self, docs: &str) -> &mut Self {
+ self.atom_doc = Some(docs.to_owned());
+ self
+ }
+
+ /// Add some documentation to the generated static set.
+ ///
+ /// This can help the user know that this type is zero-sized and just references a static
+ /// lookup table, or point them to the `Atom` type alias for more info.
+ ///
+ /// Note that `docs` should not contain the `///` at the front of normal docs.
+ pub fn with_static_set_doc(&mut self, docs: &str) -> &mut Self {
+ self.static_set_doc = Some(docs.to_owned());
+ self
+ }
+
+ /// Add some documentation to the generated macro.
+ ///
+ /// Note that `docs` should not contain the `///` at the front of normal docs.
+ pub fn with_macro_doc(&mut self, docs: &str) -> &mut Self {
+ self.macro_doc = Some(docs.to_owned());
+ self
+ }
+
+ /// Adds an atom to the builder
+ pub fn atom(&mut self, s: &str) -> &mut Self {
+ self.atoms.insert(s.to_owned());
+ self
+ }
+
+ /// Adds multiple atoms to the builder
+ pub fn atoms<I>(&mut self, iter: I) -> &mut Self
+ where
+ I: IntoIterator,
+ I::Item: AsRef<str>,
+ {
+ self.atoms
+ .extend(iter.into_iter().map(|s| s.as_ref().to_owned()));
+ self
+ }
+
+ /// Write generated code to `destination`.
+ pub fn write_to<W>(&mut self, mut destination: W) -> io::Result<()>
+ where
+ W: Write,
+ {
+ destination.write_all(
+ self.to_tokens()
+ .to_string()
+ // Insert some newlines to make the generated code slightly easier to read.
+ .replace(" [ \"", "[\n\"")
+ .replace("\" , ", "\",\n")
+ .replace(" ( \"", "\n( \"")
+ .replace("; ", ";\n")
+ .as_bytes(),
+ )
+ }
+
+ fn to_tokens(&mut self) -> proc_macro2::TokenStream {
+ // `impl Default for Atom` requires the empty string to be in the static set.
+ // This also makes sure the set in non-empty,
+ // which would cause divisions by zero in rust-phf.
+ self.atoms.insert(String::new());
+
+ let atoms: Vec<&str> = self.atoms.iter().map(|s| &**s).collect();
+ let hash_state = phf_generator::generate_hash(&atoms);
+ let phf_generator::HashState { key, disps, map } = hash_state;
+ let (disps0, disps1): (Vec<_>, Vec<_>) = disps.into_iter().unzip();
+ let atoms: Vec<&str> = map.iter().map(|&idx| atoms[idx]).collect();
+ let empty_string_index = atoms.iter().position(|s| s.is_empty()).unwrap() as u32;
+ let indices = 0..atoms.len() as u32;
+
+ let hashes: Vec<u32> = atoms
+ .iter()
+ .map(|string| {
+ let hash = phf_shared::hash(string, &key);
+ (hash.g ^ hash.f1) as u32
+ })
+ .collect();
+
+ let mut path_parts = self.path.rsplitn(2, "::");
+ let type_name = path_parts.next().unwrap();
+ let module = match path_parts.next() {
+ Some(m) => format!("$crate::{}", m),
+ None => format!("$crate"),
+ };
+ let atom_doc = match self.atom_doc {
+ Some(ref doc) => quote!(#[doc = #doc]),
+ None => quote!(),
+ };
+ let static_set_doc = match self.static_set_doc {
+ Some(ref doc) => quote!(#[doc = #doc]),
+ None => quote!(),
+ };
+ let macro_doc = match self.macro_doc {
+ Some(ref doc) => quote!(#[doc = #doc]),
+ None => quote!(),
+ };
+ let new_term =
+ |string: &str| proc_macro2::Ident::new(string, proc_macro2::Span::call_site());
+ let static_set_name = new_term(&format!("{}StaticSet", type_name));
+ let type_name = new_term(type_name);
+ let macro_name = new_term(&*self.macro_name);
+ let module = module.parse::<proc_macro2::TokenStream>().unwrap();
+ let atom_prefix = format!("ATOM_{}_", type_name.to_string().to_uppercase());
+ let const_names: Vec<_> = atoms
+ .iter()
+ .map(|atom| {
+ let mut name = atom_prefix.clone();
+ for c in atom.chars() {
+ name.push_str(&format!("_{:02X}", c as u32))
+ }
+ new_term(&name)
+ })
+ .collect();
+
+ quote! {
+ #atom_doc
+ pub type #type_name = ::string_cache::Atom<#static_set_name>;
+
+ #static_set_doc
+ #[derive(PartialEq, Eq, PartialOrd, Ord)]
+ pub struct #static_set_name;
+
+ impl ::string_cache::StaticAtomSet for #static_set_name {
+ fn get() -> &'static ::string_cache::PhfStrSet {
+ static SET: ::string_cache::PhfStrSet = ::string_cache::PhfStrSet {
+ key: #key,
+ disps: &[#((#disps0, #disps1)),*],
+ atoms: &[#(#atoms),*],
+ hashes: &[#(#hashes),*]
+ };
+ &SET
+ }
+ fn empty_string_index() -> u32 {
+ #empty_string_index
+ }
+ }
+
+ #(
+ pub const #const_names: #type_name = #type_name::pack_static(#indices);
+ )*
+
+ #macro_doc
+ #[macro_export]
+ macro_rules! #macro_name {
+ #(
+ (#atoms) => { #module::#const_names };
+ )*
+ }
+ }
+ }
+
+ /// Create a new file at `path` and write generated code there.
+ ///
+ /// Typical usage:
+ /// `.write_to_file(&Path::new(&env::var("OUT_DIR").unwrap()).join("foo_atom.rs"))`
+ pub fn write_to_file(&mut self, path: &Path) -> io::Result<()> {
+ self.write_to(BufWriter::new(File::create(path)?))
+ }
+}