summaryrefslogtreecommitdiffstats
path: root/vendor/zerofrom/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/zerofrom/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/zerofrom/Cargo.toml')
-rw-r--r--vendor/zerofrom/Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/vendor/zerofrom/Cargo.toml b/vendor/zerofrom/Cargo.toml
index 77d60c093..a0da76d79 100644
--- a/vendor/zerofrom/Cargo.toml
+++ b/vendor/zerofrom/Cargo.toml
@@ -10,9 +10,9 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "zerofrom"
-version = "0.1.1"
+version = "0.1.2"
authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
include = [
"src/**/*",
@@ -23,6 +23,7 @@ include = [
"README.md",
]
description = "ZeroFrom trait for constructing"
+readme = "README.md"
keywords = [
"zerocopy",
"serialization",
@@ -36,16 +37,18 @@ categories = [
]
license = "Unicode-DFS-2016"
repository = "https://github.com/unicode-org/icu4x"
-resolver = "2"
+
+[package.metadata.workspaces]
+independent = true
[package.metadata.docs.rs]
all-features = true
[dependencies.zerofrom-derive]
-version = "0.1.0"
+version = "0.1.1"
optional = true
[features]
alloc = []
default = ["alloc"]
-derive = ["zerofrom-derive"]
+derive = ["dep:zerofrom-derive"]