summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0004-clippy-feature-sync.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0004-clippy-feature-sync.patch')
-rw-r--r--debian/patches/d-0004-clippy-feature-sync.patch17
1 files changed, 11 insertions, 6 deletions
diff --git a/debian/patches/d-0004-clippy-feature-sync.patch b/debian/patches/d-0004-clippy-feature-sync.patch
index 086ece034..23667ffde 100644
--- a/debian/patches/d-0004-clippy-feature-sync.patch
+++ b/debian/patches/d-0004-clippy-feature-sync.patch
@@ -6,14 +6,14 @@ enable features needed by rustfmt to make build system happy and speedup build.
this is what rustc_workspace_hack does in the upstream build.
---
src/tools/clippy/Cargo.toml | 2 +-
- src/tools/rustfmt/Cargo.toml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ src/tools/rustfmt/Cargo.toml | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index 3aa9ec6..0bb813d 100644
+index c7c6c3e..7e453c7 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
-@@ -43,7 +43,7 @@ if_chain = "1.0"
+@@ -44,7 +44,7 @@ if_chain = "1.0"
itertools = "0.10.1"
quote = "1.0"
serde = { version = "1.0.125", features = ["derive"] }
@@ -23,10 +23,15 @@ index 3aa9ec6..0bb813d 100644
parking_lot = "0.12"
tokio = { version = "1", features = ["io-util"] }
diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
-index 27b91f2..12d1567 100644
+index 12ed654..f85b738 100644
--- a/src/tools/rustfmt/Cargo.toml
+++ b/src/tools/rustfmt/Cargo.toml
-@@ -49,7 +49,7 @@ lazy_static = "1.4"
+@@ -46,10 +46,12 @@ getopts = "0.2"
+ ignore = "0.4"
+ itertools = "0.10"
+ lazy_static = "1.4"
++# added for sync with clippy
++libc = { version = "0.2", features = ["extra_traits"] }
log = "0.4"
regex = "1.5"
serde = { version = "1.0", features = ["derive"] }