summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch38
-rw-r--r--debian/patches/d-0003-cc-psm-rebuild-wasm32.patch4
-rw-r--r--debian/patches/d-0004-clippy-feature-sync.patch17
-rw-r--r--debian/patches/d-0005-no-jemalloc.patch16
-rw-r--r--debian/patches/d-bootstrap-cargo-doc-paths.patch18
-rw-r--r--debian/patches/u-fix-sysroot-detection-logic.patch16
-rw-r--r--debian/patches/u-reproducible-dl-stage0.patch18
7 files changed, 67 insertions, 60 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 6c3b0cfad..2f1c323c3 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -59,13 +59,13 @@ index 15cbb26..c012319 100644
# See comments in `library/rustc-std-workspace-core/README.md` for what's going on
# here
diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
-index 9cf43fc..39b985f 100644
+index 013d1ab..f6fd37b 100644
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
-@@ -770,10 +770,6 @@ class RustBuild(object):
+@@ -777,10 +777,6 @@ class RustBuild(object):
+ args = [self.cargo(), "build", "--manifest-path",
os.path.join(self.rust_root, "src/bootstrap/Cargo.toml")]
- for _ in range(0, self.verbose):
- args.append("--verbose")
+ args.extend("--verbose" for _ in range(verbose_count))
- if self.use_locked_deps:
- args.append("--locked")
- if self.use_vendored_sources:
@@ -74,7 +74,7 @@ index 9cf43fc..39b985f 100644
args.append("--features")
args.append("build-metrics")
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index b4fc1d4..2bb0659 100644
+index b33fc02..4492577 100644
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
@@ -629,8 +629,6 @@ impl<'a> Builder<'a> {
@@ -134,7 +134,7 @@ index b4fc1d4..2bb0659 100644
install::Rustfmt,
install::RustDemangler,
install::Clippy,
-@@ -1889,10 +1876,7 @@ impl<'a> Builder<'a> {
+@@ -1878,10 +1865,7 @@ impl<'a> Builder<'a> {
}
}
@@ -147,10 +147,10 @@ index b4fc1d4..2bb0659 100644
}
diff --git a/src/bootstrap/doc.rs b/src/bootstrap/doc.rs
-index 9bad904..d02edb0 100644
+index cc80763..19754a2 100644
--- a/src/bootstrap/doc.rs
+++ b/src/bootstrap/doc.rs
-@@ -75,7 +75,6 @@ macro_rules! book {
+@@ -76,7 +76,6 @@ macro_rules! book {
// FIXME: Make checking for a submodule automatic somehow (maybe by having a list of all submodules
// and checking against it?).
book!(
@@ -159,10 +159,10 @@ index 9bad904..d02edb0 100644
EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
diff --git a/src/bootstrap/test.rs b/src/bootstrap/test.rs
-index 6078e39..1a385f5 100644
+index b4f1506..27236f3 100644
--- a/src/bootstrap/test.rs
+++ b/src/bootstrap/test.rs
-@@ -2005,17 +2005,7 @@ impl Step for RustcGuide {
+@@ -2024,17 +2024,7 @@ impl Step for RustcGuide {
}
fn run(self, builder: &Builder<'_>) {
@@ -182,7 +182,7 @@ index 6078e39..1a385f5 100644
}
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index f8cb4b7..3aa9ec6 100644
+index 70d1268..c7c6c3e 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
@@ -36,11 +36,6 @@ walkdir = "2.3"
@@ -195,10 +195,10 @@ index f8cb4b7..3aa9ec6 100644
-rustc-workspace-hack = "1.0"
-
# UI test dependencies
+ clap = { version = "4.1.4", features = ["derive"] }
clippy_utils = { path = "clippy_utils" }
- derive-new = "0.5"
diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
-index 286ef1e..3d68711 100644
+index 333f03c..2a0faa2 100644
--- a/src/tools/rust-analyzer/Cargo.toml
+++ b/src/tools/rust-analyzer/Cargo.toml
@@ -1,5 +1,14 @@
@@ -216,14 +216,14 @@ index 286ef1e..3d68711 100644
+]
exclude = ["crates/proc-macro-test/imp"]
- [profile.dev]
+ [workspace.package]
diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
-index 7a4e02d..27b91f2 100644
+index 87ce59d..12ed654 100644
--- a/src/tools/rustfmt/Cargo.toml
+++ b/src/tools/rustfmt/Cargo.toml
@@ -59,11 +59,6 @@ unicode_categories = "0.1"
- rustfmt-config_proc_macro = { version = "0.2", path = "config_proc_macro" }
+ rustfmt-config_proc_macro = { version = "0.3", path = "config_proc_macro" }
-# A noop dependency that changes in the Rust repository, it's a bit of a hack.
-# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
@@ -234,10 +234,10 @@ index 7a4e02d..27b91f2 100644
[package.metadata.rust-analyzer]
diff --git a/src/tools/tidy/src/deps.rs b/src/tools/tidy/src/deps.rs
-index bc2edf6..142c2e9 100644
+index bddfdcf..9bac4b7 100644
--- a/src/tools/tidy/src/deps.rs
+++ b/src/tools/tidy/src/deps.rs
-@@ -332,7 +332,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
+@@ -333,7 +333,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
// This crate takes quite a long time to build, so don't allow two versions of them
// to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
// under control.
@@ -246,7 +246,7 @@ index bc2edf6..142c2e9 100644
];
/// Dependency checks.
-@@ -608,6 +608,8 @@ fn direct_deps_of<'a>(metadata: &'a Metadata, pkg_id: &'a PackageId) -> Vec<&'a
+@@ -609,6 +609,8 @@ fn direct_deps_of<'a>(metadata: &'a Metadata, pkg_id: &'a PackageId) -> Vec<&'a
}
fn check_rustfix(metadata: &Metadata, bad: &mut bool) {
diff --git a/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch b/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
index d17b24beb..703df2a78 100644
--- a/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
+++ b/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
@@ -8,10 +8,10 @@ Subject: d-0003-cc-psm-rebuild-wasm32
2 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/vendor/cc/src/lib.rs b/vendor/cc/src/lib.rs
-index 486d67e..723b2e9 100644
+index 1ebd2cc..0d6ebc8 100644
--- a/vendor/cc/src/lib.rs
+++ b/vendor/cc/src/lib.rs
-@@ -2369,7 +2369,7 @@ impl Build {
+@@ -2389,7 +2389,7 @@ impl Build {
|| target == "wasm32-unknown-wasi"
|| target == "wasm32-unknown-unknown"
{
diff --git a/debian/patches/d-0004-clippy-feature-sync.patch b/debian/patches/d-0004-clippy-feature-sync.patch
index 086ece034..23667ffde 100644
--- a/debian/patches/d-0004-clippy-feature-sync.patch
+++ b/debian/patches/d-0004-clippy-feature-sync.patch
@@ -6,14 +6,14 @@ enable features needed by rustfmt to make build system happy and speedup build.
this is what rustc_workspace_hack does in the upstream build.
---
src/tools/clippy/Cargo.toml | 2 +-
- src/tools/rustfmt/Cargo.toml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ src/tools/rustfmt/Cargo.toml | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index 3aa9ec6..0bb813d 100644
+index c7c6c3e..7e453c7 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
-@@ -43,7 +43,7 @@ if_chain = "1.0"
+@@ -44,7 +44,7 @@ if_chain = "1.0"
itertools = "0.10.1"
quote = "1.0"
serde = { version = "1.0.125", features = ["derive"] }
@@ -23,10 +23,15 @@ index 3aa9ec6..0bb813d 100644
parking_lot = "0.12"
tokio = { version = "1", features = ["io-util"] }
diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
-index 27b91f2..12d1567 100644
+index 12ed654..f85b738 100644
--- a/src/tools/rustfmt/Cargo.toml
+++ b/src/tools/rustfmt/Cargo.toml
-@@ -49,7 +49,7 @@ lazy_static = "1.4"
+@@ -46,10 +46,12 @@ getopts = "0.2"
+ ignore = "0.4"
+ itertools = "0.10"
+ lazy_static = "1.4"
++# added for sync with clippy
++libc = { version = "0.2", features = ["extra_traits"] }
log = "0.4"
regex = "1.5"
serde = { version = "1.0", features = ["derive"] }
diff --git a/debian/patches/d-0005-no-jemalloc.patch b/debian/patches/d-0005-no-jemalloc.patch
index ac23de8bb..17254fb53 100644
--- a/debian/patches/d-0005-no-jemalloc.patch
+++ b/debian/patches/d-0005-no-jemalloc.patch
@@ -8,10 +8,10 @@ Subject: d-0005-no-jemalloc
2 files changed, 8 deletions(-)
diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
-index 27ee3dd..87fb29f 100644
+index 41003ad..0578f7b 100644
--- a/compiler/rustc/Cargo.toml
+++ b/compiler/rustc/Cargo.toml
-@@ -13,13 +13,7 @@ rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
+@@ -14,13 +14,7 @@ rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
# crate is intended to be used by stable MIR consumers, which are not in-tree
rustc_smir = { path = "../rustc_smir" }
@@ -22,14 +22,14 @@ index 27ee3dd..87fb29f 100644
-
[features]
-jemalloc = ['jemalloc-sys']
- llvm = ['rustc_driver/llvm']
- max_level_info = ['rustc_driver/max_level_info']
- rustc_use_parallel_compiler = ['rustc_driver/rustc_use_parallel_compiler']
+ llvm = ['rustc_driver_impl/llvm']
+ max_level_info = ['rustc_driver_impl/max_level_info']
+ rustc_use_parallel_compiler = ['rustc_driver_impl/rustc_use_parallel_compiler']
diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-index 01d1735..bf0ba06 100644
+index 6273ea5..642fb05 100644
--- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-@@ -15,7 +15,6 @@ cfg-if = "1.0.0"
+@@ -17,7 +17,6 @@ cfg-if = "1.0.0"
libc = "0.2.135"
la-arena = { version = "0.3.0", path = "../../lib/la-arena" }
countme = { version = "3.0.1", features = ["enable"] }
@@ -37,7 +37,7 @@ index 01d1735..bf0ba06 100644
[target.'cfg(target_os = "linux")'.dependencies]
perf-event = "0.4.7"
-@@ -25,7 +24,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
+@@ -27,7 +26,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
[features]
cpu_profiler = []
diff --git a/debian/patches/d-bootstrap-cargo-doc-paths.patch b/debian/patches/d-bootstrap-cargo-doc-paths.patch
index baba25534..8b6b5a82a 100644
--- a/debian/patches/d-bootstrap-cargo-doc-paths.patch
+++ b/debian/patches/d-bootstrap-cargo-doc-paths.patch
@@ -93,15 +93,15 @@ diff --git a/src/doc/index.md b/src/doc/index.md
index 2c92d5e..9be58d5 100644
--- a/src/doc/index.md
+++ b/src/doc/index.md
-@@ -87,7 +87,7 @@ accomplishing various tasks.
+@@ -130,7 +130,7 @@
- ## The Cargo Book
+ ### The Cargo Book
--[The Cargo Book](cargo/index.html) is a guide to Cargo, Rust's build tool and dependency manager.
-+[The Cargo Book](../../cargo-doc/doc/index.html) is a guide to Cargo, Rust's build tool and dependency manager.
-
- ## The Rustdoc Book
+-[The Cargo Book](cargo/index.html) is a guide to Cargo, Rust's build tool and
++[The Cargo Book](../../cargo-doc/doc/index.html) is a guide to Cargo, Rust's build tool and
+ dependency manager.
+ ### The Rustdoc Book
diff --git a/src/doc/reference/src/conditional-compilation.md b/src/doc/reference/src/conditional-compilation.md
index 6966cec..0ca3589 100644
--- a/src/doc/reference/src/conditional-compilation.md
@@ -353,9 +353,9 @@ Index: rust/src/doc/rustc/src/linker-plugin-lto.md
environment variables:
Index: rust/src/doc/rustc/src/platform-support/fuchsia.md
===================================================================
---- rust.orig/src/doc/rustc/src/platform-support/fuchsia.md
-+++ rust/src/doc/rustc/src/platform-support/fuchsia.md
-@@ -870,7 +870,7 @@ ${SDK_PATH}/tools/${ARCH}/ffx debug conn
+--- a/src/doc/rustc/src/platform-support/fuchsia.md
++++ b/src/doc/rustc/src/platform-support/fuchsia.md
+@@ -932,7 +932,7 @@
[Fuchsia]: https://fuchsia.dev/
[source tree]: https://fuchsia.dev/fuchsia-src/get-started/learn/build
[rustup]: https://rustup.rs/
diff --git a/debian/patches/u-fix-sysroot-detection-logic.patch b/debian/patches/u-fix-sysroot-detection-logic.patch
index 3bb0797ba..64cc291f7 100644
--- a/debian/patches/u-fix-sysroot-detection-logic.patch
+++ b/debian/patches/u-fix-sysroot-detection-logic.patch
@@ -6,7 +6,7 @@ Description: Fix sysroot detection which would result in /usr/lib/lib/rustlib
Bug: https://github.com/rust-lang/rust/issues/109994
--- a/compiler/rustc_session/src/filesearch.rs
+++ b/compiler/rustc_session/src/filesearch.rs
-@@ -180,18 +180,29 @@
+@@ -179,7 +179,7 @@
))?;
// if `dir` points target's dir, move up to the sysroot
@@ -14,15 +14,17 @@ Bug: https://github.com/rust-lang/rust/issues/109994
+ let mut sysroot_dir = if dir.ends_with(crate::config::host_triple()) {
dir.parent() // chop off `$target`
.and_then(|p| p.parent()) // chop off `rustlib`
- .and_then(|p| p.parent()) // chop off `lib`
+ .and_then(|p| {
+@@ -194,13 +194,25 @@
+ }
+ })
.map(|s| s.to_owned())
- .ok_or(format!(
-- "Could not move 3 levels upper using `parent()` on {}",
-- dir.display()
++ .ok_or_else(|| format!(
+ "Could not move 3 levels upper using `parent()` on {}",
+ dir.display()
- ))
-+ .ok_or_else(|| {
-+ format!("Could not move 3 levels upper using `parent()` on {}", dir.display())
-+ })?
++ ))?
} else {
- Ok(dir.to_owned())
+ dir.to_owned()
diff --git a/debian/patches/u-reproducible-dl-stage0.patch b/debian/patches/u-reproducible-dl-stage0.patch
index b6ba259ec..0ac05cb8b 100644
--- a/debian/patches/u-reproducible-dl-stage0.patch
+++ b/debian/patches/u-reproducible-dl-stage0.patch
@@ -11,12 +11,12 @@ diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
index ab4338e..0227735 100644
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
-@@ -92,7 +92,7 @@ def _download(path, url, probably_big, v
- "-L", # Follow redirect.
- "-y", "30", "-Y", "10", # timeout if speed is < 10 bytes/sec for > 30 seconds
- "--connect-timeout", "30", # timeout if cannot connect within 30 seconds
-- "--retry", "3", "-Sf", "-o", path, url],
-+ "--retry", "3", "-Sf", "-o", path, "-R", url],
- verbose=verbose,
- exception=True, # Will raise RuntimeError on failure
- )
+@@ -92,7 +92,7 @@
+ "-L", # Follow redirect.
+ "-y", "30", "-Y", "10", # timeout if speed is < 10 bytes/sec for > 30 seconds
+ "--connect-timeout", "30", # timeout if cannot connect within 30 seconds
+- "--retry", "3", "-Sf", url],
++ "--retry", "3", "-Sf", "-R", url],
+ stdout=outfile, #Implements cli redirect operator '>'
+ verbose=verbose,
+ exception=True, # Will raise RuntimeError on failure