summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/link-path-order/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/link-path-order/Makefile')
-rw-r--r--tests/run-make-fulldeps/link-path-order/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/tests/run-make-fulldeps/link-path-order/Makefile b/tests/run-make-fulldeps/link-path-order/Makefile
deleted file mode 100644
index ed7c299e6..000000000
--- a/tests/run-make-fulldeps/link-path-order/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../tools.mk
-
-# Verifies that the -L arguments given to the linker is in the same order
-# as the -L arguments on the rustc command line.
-
-CORRECT_DIR=$(TMPDIR)/correct
-WRONG_DIR=$(TMPDIR)/wrong
-
-F := $(call NATIVE_STATICLIB_FILE,foo)
-
-all: $(call NATIVE_STATICLIB,correct) $(call NATIVE_STATICLIB,wrong)
- mkdir -p $(CORRECT_DIR) $(WRONG_DIR)
- mv $(call NATIVE_STATICLIB,correct) $(CORRECT_DIR)/$(F)
- mv $(call NATIVE_STATICLIB,wrong) $(WRONG_DIR)/$(F)
- $(RUSTC) main.rs -o $(TMPDIR)/should_succeed -L $(CORRECT_DIR) -L $(WRONG_DIR)
- $(call RUN,should_succeed)
- $(RUSTC) main.rs -o $(TMPDIR)/should_fail -L $(WRONG_DIR) -L $(CORRECT_DIR)
- $(call FAIL,should_fail)