summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/link-path-order
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/link-path-order')
-rw-r--r--tests/run-make-fulldeps/link-path-order/Makefile18
-rw-r--r--tests/run-make-fulldeps/link-path-order/correct.c1
-rw-r--r--tests/run-make-fulldeps/link-path-order/main.rs16
-rw-r--r--tests/run-make-fulldeps/link-path-order/wrong.c1
4 files changed, 0 insertions, 36 deletions
diff --git a/tests/run-make-fulldeps/link-path-order/Makefile b/tests/run-make-fulldeps/link-path-order/Makefile
deleted file mode 100644
index ed7c299e6..000000000
--- a/tests/run-make-fulldeps/link-path-order/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../tools.mk
-
-# Verifies that the -L arguments given to the linker is in the same order
-# as the -L arguments on the rustc command line.
-
-CORRECT_DIR=$(TMPDIR)/correct
-WRONG_DIR=$(TMPDIR)/wrong
-
-F := $(call NATIVE_STATICLIB_FILE,foo)
-
-all: $(call NATIVE_STATICLIB,correct) $(call NATIVE_STATICLIB,wrong)
- mkdir -p $(CORRECT_DIR) $(WRONG_DIR)
- mv $(call NATIVE_STATICLIB,correct) $(CORRECT_DIR)/$(F)
- mv $(call NATIVE_STATICLIB,wrong) $(WRONG_DIR)/$(F)
- $(RUSTC) main.rs -o $(TMPDIR)/should_succeed -L $(CORRECT_DIR) -L $(WRONG_DIR)
- $(call RUN,should_succeed)
- $(RUSTC) main.rs -o $(TMPDIR)/should_fail -L $(WRONG_DIR) -L $(CORRECT_DIR)
- $(call FAIL,should_fail)
diff --git a/tests/run-make-fulldeps/link-path-order/correct.c b/tests/run-make-fulldeps/link-path-order/correct.c
deleted file mode 100644
index 3064af952..000000000
--- a/tests/run-make-fulldeps/link-path-order/correct.c
+++ /dev/null
@@ -1 +0,0 @@
-int should_return_one() { return 1; }
diff --git a/tests/run-make-fulldeps/link-path-order/main.rs b/tests/run-make-fulldeps/link-path-order/main.rs
deleted file mode 100644
index 8024e343d..000000000
--- a/tests/run-make-fulldeps/link-path-order/main.rs
+++ /dev/null
@@ -1,16 +0,0 @@
-#![feature(rustc_private)]
-
-extern crate libc;
-
-#[link(name = "foo", kind = "static")]
-extern "C" {
- fn should_return_one() -> libc::c_int;
-}
-
-fn main() {
- let result = unsafe { should_return_one() };
-
- if result != 1 {
- std::process::exit(255);
- }
-}
diff --git a/tests/run-make-fulldeps/link-path-order/wrong.c b/tests/run-make-fulldeps/link-path-order/wrong.c
deleted file mode 100644
index 64275b3ad..000000000
--- a/tests/run-make-fulldeps/link-path-order/wrong.c
+++ /dev/null
@@ -1 +0,0 @@
-int should_return_one() { return 0; }