summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-24445/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-24445/Makefile')
-rw-r--r--tests/run-make/issue-24445/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/issue-24445/Makefile b/tests/run-make/issue-24445/Makefile
new file mode 100644
index 000000000..a13910aa7
--- /dev/null
+++ b/tests/run-make/issue-24445/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# only-linux
+
+all:
+ $(RUSTC) foo.rs
+ $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -o $(TMPDIR)/foo
+ $(call RUN,foo)
+ $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -pie -fPIC -o $(TMPDIR)/foo
+ $(call RUN,foo)