summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-24445
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-24445')
-rw-r--r--tests/run-make/issue-24445/Makefile11
-rw-r--r--tests/run-make/issue-24445/foo.c6
-rw-r--r--tests/run-make/issue-24445/foo.rs15
3 files changed, 32 insertions, 0 deletions
diff --git a/tests/run-make/issue-24445/Makefile b/tests/run-make/issue-24445/Makefile
new file mode 100644
index 000000000..a13910aa7
--- /dev/null
+++ b/tests/run-make/issue-24445/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# only-linux
+
+all:
+ $(RUSTC) foo.rs
+ $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -o $(TMPDIR)/foo
+ $(call RUN,foo)
+ $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -pie -fPIC -o $(TMPDIR)/foo
+ $(call RUN,foo)
diff --git a/tests/run-make/issue-24445/foo.c b/tests/run-make/issue-24445/foo.c
new file mode 100644
index 000000000..bb4036b06
--- /dev/null
+++ b/tests/run-make/issue-24445/foo.c
@@ -0,0 +1,6 @@
+void foo();
+
+int main() {
+ foo();
+ return 0;
+}
diff --git a/tests/run-make/issue-24445/foo.rs b/tests/run-make/issue-24445/foo.rs
new file mode 100644
index 000000000..b67f3847c
--- /dev/null
+++ b/tests/run-make/issue-24445/foo.rs
@@ -0,0 +1,15 @@
+#![crate_type = "staticlib"]
+
+struct Destroy;
+impl Drop for Destroy {
+ fn drop(&mut self) { println!("drop"); }
+}
+
+thread_local! {
+ static X: Destroy = Destroy
+}
+
+#[no_mangle]
+pub extern "C" fn foo() {
+ X.with(|_| ());
+}