summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rlib-chain/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rlib-chain/Makefile')
-rw-r--r--tests/run-make/rlib-chain/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/rlib-chain/Makefile b/tests/run-make/rlib-chain/Makefile
new file mode 100644
index 000000000..7a1f887fa
--- /dev/null
+++ b/tests/run-make/rlib-chain/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) m1.rs
+ $(RUSTC) m2.rs
+ $(RUSTC) m3.rs
+ $(RUSTC) m4.rs
+ $(call RUN,m4)
+ rm $(TMPDIR)/*lib
+ $(call RUN,m4)