summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rlib-chain
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rlib-chain')
-rw-r--r--tests/run-make/rlib-chain/Makefile11
-rw-r--r--tests/run-make/rlib-chain/m1.rs2
-rw-r--r--tests/run-make/rlib-chain/m2.rs4
-rw-r--r--tests/run-make/rlib-chain/m3.rs4
-rw-r--r--tests/run-make/rlib-chain/m4.rs3
5 files changed, 24 insertions, 0 deletions
diff --git a/tests/run-make/rlib-chain/Makefile b/tests/run-make/rlib-chain/Makefile
new file mode 100644
index 000000000..7a1f887fa
--- /dev/null
+++ b/tests/run-make/rlib-chain/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) m1.rs
+ $(RUSTC) m2.rs
+ $(RUSTC) m3.rs
+ $(RUSTC) m4.rs
+ $(call RUN,m4)
+ rm $(TMPDIR)/*lib
+ $(call RUN,m4)
diff --git a/tests/run-make/rlib-chain/m1.rs b/tests/run-make/rlib-chain/m1.rs
new file mode 100644
index 000000000..665b206cc
--- /dev/null
+++ b/tests/run-make/rlib-chain/m1.rs
@@ -0,0 +1,2 @@
+#![crate_type = "rlib"]
+pub fn m1() {}
diff --git a/tests/run-make/rlib-chain/m2.rs b/tests/run-make/rlib-chain/m2.rs
new file mode 100644
index 000000000..eba12fe12
--- /dev/null
+++ b/tests/run-make/rlib-chain/m2.rs
@@ -0,0 +1,4 @@
+#![crate_type = "rlib"]
+extern crate m1;
+
+pub fn m2() { m1::m1() }
diff --git a/tests/run-make/rlib-chain/m3.rs b/tests/run-make/rlib-chain/m3.rs
new file mode 100644
index 000000000..ade191db4
--- /dev/null
+++ b/tests/run-make/rlib-chain/m3.rs
@@ -0,0 +1,4 @@
+#![crate_type = "rlib"]
+extern crate m2;
+
+pub fn m3() { m2::m2() }
diff --git a/tests/run-make/rlib-chain/m4.rs b/tests/run-make/rlib-chain/m4.rs
new file mode 100644
index 000000000..fa8ec6079
--- /dev/null
+++ b/tests/run-make/rlib-chain/m4.rs
@@ -0,0 +1,3 @@
+extern crate m3;
+
+fn main() { m3::m3() }