summaryrefslogtreecommitdiffstats
path: root/tests/run-make/simple-rlib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/simple-rlib')
-rw-r--r--tests/run-make/simple-rlib/Makefile6
-rw-r--r--tests/run-make/simple-rlib/bar.rs1
-rw-r--r--tests/run-make/simple-rlib/foo.rs5
3 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/simple-rlib/Makefile b/tests/run-make/simple-rlib/Makefile
new file mode 100644
index 000000000..28df61a15
--- /dev/null
+++ b/tests/run-make/simple-rlib/Makefile
@@ -0,0 +1,6 @@
+# ignore-cross-compile
+include ../tools.mk
+all:
+ $(RUSTC) bar.rs --crate-type=rlib
+ $(RUSTC) foo.rs
+ $(call RUN,foo)
diff --git a/tests/run-make/simple-rlib/bar.rs b/tests/run-make/simple-rlib/bar.rs
new file mode 100644
index 000000000..c5c0bc606
--- /dev/null
+++ b/tests/run-make/simple-rlib/bar.rs
@@ -0,0 +1 @@
+pub fn bar() {}
diff --git a/tests/run-make/simple-rlib/foo.rs b/tests/run-make/simple-rlib/foo.rs
new file mode 100644
index 000000000..8d68535e3
--- /dev/null
+++ b/tests/run-make/simple-rlib/foo.rs
@@ -0,0 +1,5 @@
+extern crate bar;
+
+fn main() {
+ bar::bar();
+}