summaryrefslogtreecommitdiffstats
path: root/configs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:46:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:46:56 +0000
commit8e79ad9f544d1c4a0476e0d96aef0496ca7fc741 (patch)
treecda1743f5820600fd8c638ac7f034f917ac8c381 /configs
parentInitial commit. (diff)
downloadsbuild-8e79ad9f544d1c4a0476e0d96aef0496ca7fc741.tar.xz
sbuild-8e79ad9f544d1c4a0476e0d96aef0496ca7fc741.zip
Adding upstream version 0.85.6.upstream/0.85.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configs')
-rw-r--r--configs/Makefile.am33
-rw-r--r--configs/README18
-rw-r--r--configs/ref-oldstable58
-rw-r--r--configs/ref-stable63
-rw-r--r--configs/ref-testing76
-rw-r--r--configs/ref-unstable80
6 files changed, 328 insertions, 0 deletions
diff --git a/configs/Makefile.am b/configs/Makefile.am
new file mode 100644
index 0000000..0b23fcb
--- /dev/null
+++ b/configs/Makefile.am
@@ -0,0 +1,33 @@
+# sbuild Makefile template
+#
+#
+# Copyright © 2004-2007 Roger Leigh <rleigh@debian.org>
+#
+# sbuild is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# sbuild is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+include $(top_srcdir)/scripts/global.mk
+
+exampleconfdir = $(docdir)/configs
+exampleconf_DATA = \
+ README \
+ ref-oldstable \
+ ref-stable \
+ ref-testing \
+ ref-unstable
+
+EXTRA_DIST = \
+ $(exampleconf_DATA) \ No newline at end of file
diff --git a/configs/README b/configs/README
new file mode 100644
index 0000000..0d9c0be
--- /dev/null
+++ b/configs/README
@@ -0,0 +1,18 @@
+The ref-* files are used by checkchroot to find unwanted packages in the chroots.
+
+# cp ref-* /usr/local/chroot/
+
+ - stable-old is potato
+ - stable is woody
+ - different for diff arches
+ - you can basically get the list using something like:
+
+ grep-available -F priority -e -s package "(required|standard)" $CHROOT/var/lib/dpkg/available| \
+ awk '{print $2}'|sort
+
+ - the only extras should be:
+ apt
+ build-essential
+ fakeroot (some arches only use sudo and change $fakeroot config item)
+ ssmtp
+ sudo
diff --git a/configs/ref-oldstable b/configs/ref-oldstable
new file mode 100644
index 0000000..5cdd8f7
--- /dev/null
+++ b/configs/ref-oldstable
@@ -0,0 +1,58 @@
+apt
+base-files
+base-passwd
+bash
+binutils
+bsdutils
+build-essential
+cpio
+cpp
+debianutils
+diff
+dpkg
+dpkg-dev
+e2fsprogs
+fakeroot
+fileutils
+findutils
+g++
+gcc
+grep
+gzip
+hostname
+ldso
+libc6
+libc6-dev
+libdb2
+libgdbmg1
+libncurses5
+libpam-modules
+libpam-runtime
+libpam0g
+libreadline4
+libstdc++2.10
+libstdc++2.10-dev
+login
+make
+makedev
+mawk
+modutils
+mount
+ncurses-base
+ncurses-bin
+passwd
+patch
+perl-5.005
+perl-5.005-base
+perl-base
+procps
+sed
+shellutils
+slang1
+ssmtp
+sudo
+sysvinit
+tar
+textutils
+update
+util-linux
diff --git a/configs/ref-stable b/configs/ref-stable
new file mode 100644
index 0000000..31bd023
--- /dev/null
+++ b/configs/ref-stable
@@ -0,0 +1,63 @@
+apt
+base-files
+base-passwd
+bash
+binutils
+bsdutils
+build-essential
+cpio
+cpp
+cpp-2.95
+debconf
+debianutils
+diff
+dpkg
+dpkg-dev
+e2fsprogs
+fakeroot
+fileutils
+findutils
+g++
+g++-2.95
+gcc
+gcc-2.95
+grep
+gzip
+hostname
+libc6
+libc6-dev
+libcap1
+libdb2
+libdb3
+libgdbmg1
+libncurses5
+libpam-modules
+libpam-runtime
+libpam0g
+libperl5.6
+libreadline4
+libstdc++2.10-dev
+libstdc++2.10-glibc2.2
+login
+make
+makedev
+mawk
+modutils
+mount
+ncurses-base
+ncurses-bin
+passwd
+patch
+perl
+perl-base
+perl-modules
+procps
+sed
+shellutils
+slang1
+ssmtp
+sudo
+sysvinit
+tar
+textutils
+util-linux
diff --git a/configs/ref-testing b/configs/ref-testing
new file mode 100644
index 0000000..71a0eb3
--- /dev/null
+++ b/configs/ref-testing
@@ -0,0 +1,76 @@
+apt
+base-files
+base-passwd
+bash
+binutils
+bsdutils
+build-essential
+coreutils
+cpio
+cpp
+cpp-3.3
+debianutils
+diff
+dpkg
+dpkg-dev
+dselect
+e2fslibs
+e2fsprogs
+fakeroot
+file
+findutils
+g++
+g++-3.3
+gcc
+gcc-3.3
+gcc-3.3-base
+gettext-base
+grep
+gzip
+hostname
+initscripts
+libacl1
+libattr1
+libblkid1
+libc6
+libc6-dev
+libcap1
+libcomerr2
+libdb1-compat
+libdb3
+libdb4.2
+libgcc1
+libgdbm3
+libmagic1
+libncurses5
+libpam0g
+libpam-modules
+libpam-runtime
+libss2
+libssl0.9.7
+libstdc++5
+libstdc++5-3.3-dev
+libuuid1
+linux-kernel-headers
+login
+make
+makedev
+mawk
+mount
+ncurses-base
+ncurses-bin
+passwd
+patch
+perl
+perl-base
+perl-modules
+sed
+slang1
+slang1a-utf8
+ssmtp
+sudo
+sysvinit
+sysv-rc
+tar
+util-linux
+zlib1g
diff --git a/configs/ref-unstable b/configs/ref-unstable
new file mode 100644
index 0000000..29f70d8
--- /dev/null
+++ b/configs/ref-unstable
@@ -0,0 +1,80 @@
+apt
+base-files
+base-passwd
+bash
+binutils
+bison
+bsdutils
+build-essential
+coreutils
+cpp
+cpp-3.3
+debianutils
+diff
+dpkg
+dpkg-dev
+dselect
+e2fslibs
+e2fsprogs
+fakeroot
+file
+findutils
+flex
+g++
+g++-3.3
+gcc
+gcc-3.3
+gcc-3.3-base
+gettext-base
+grep
+gzip
+hostname
+initscripts
+libacl1
+libattr1
+libblkid1
+libc6
+libc6-dev
+libcap1
+libcomerr2
+libdb1-compat
+libdb3
+libdb4.2
+libgcc1
+libgdbm3
+libgpmg1
+liblocale-gettext-perl
+libmagic1
+libncurses5
+libpam0g
+libpam-modules
+libpam-runtime
+libss2
+libssl0.9.7
+libstdc++5
+libstdc++5-3.3-dev
+libuuid1
+linux-kernel-headers
+login
+m4
+make
+makedev
+mawk
+mount
+ncurses-base
+ncurses-bin
+passwd
+patch
+perl
+perl-base
+perl-modules
+sed
+slang1
+slang1a-utf8
+ssmtp
+sudo
+sysvinit
+sysv-rc
+tar
+util-linux
+zlib1g