summaryrefslogtreecommitdiffstats
path: root/Makefile.pypi
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:07:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:07:52 +0000
commitf0f453c916e279980df981c1e1dee0d167dc124e (patch)
treed09973c9f173820ade2dc814467d3e57df8a042d /Makefile.pypi
parentInitial commit. (diff)
downloadssh-audit-f0f453c916e279980df981c1e1dee0d167dc124e.tar.xz
ssh-audit-f0f453c916e279980df981c1e1dee0d167dc124e.zip
Adding upstream version 3.1.0.upstream/3.1.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.pypi')
-rw-r--r--Makefile.pypi15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.pypi b/Makefile.pypi
new file mode 100644
index 0000000..56bb404
--- /dev/null
+++ b/Makefile.pypi
@@ -0,0 +1,15 @@
+all:
+ rm -rf /tmp/pypi_upload
+ virtualenv -p /usr/bin/python3 /tmp/pypi_upload/
+ cp -R src /tmp/pypi_upload/
+ cp setup.py setup.cfg README.md LICENSE /tmp/pypi_upload/
+ /bin/bash -c "pushd /tmp/pypi_upload/; source bin/activate; pip3 install -U setuptools twine build; pip3 install -U requests_toolbelt; python3 -m build"
+
+uploadtest:
+ /bin/bash -c "pushd /tmp/pypi_upload; source bin/activate; python3 -m twine upload --repository testpypi /tmp/pypi_upload/dist/*"
+
+uploadprod:
+ /bin/bash -c "pushd /tmp/pypi_upload; source bin/activate; twine upload /tmp/pypi_upload/dist/*"
+
+clean:
+ rm -rf /tmp/pypi_upload/