summaryrefslogtreecommitdiffstats
path: root/Makefile.pypi
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.pypi')
-rw-r--r--Makefile.pypi15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.pypi b/Makefile.pypi
new file mode 100644
index 0000000..56bb404
--- /dev/null
+++ b/Makefile.pypi
@@ -0,0 +1,15 @@
+all:
+ rm -rf /tmp/pypi_upload
+ virtualenv -p /usr/bin/python3 /tmp/pypi_upload/
+ cp -R src /tmp/pypi_upload/
+ cp setup.py setup.cfg README.md LICENSE /tmp/pypi_upload/
+ /bin/bash -c "pushd /tmp/pypi_upload/; source bin/activate; pip3 install -U setuptools twine build; pip3 install -U requests_toolbelt; python3 -m build"
+
+uploadtest:
+ /bin/bash -c "pushd /tmp/pypi_upload; source bin/activate; python3 -m twine upload --repository testpypi /tmp/pypi_upload/dist/*"
+
+uploadprod:
+ /bin/bash -c "pushd /tmp/pypi_upload; source bin/activate; twine upload /tmp/pypi_upload/dist/*"
+
+clean:
+ rm -rf /tmp/pypi_upload/