summaryrefslogtreecommitdiffstats
path: root/factory
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /factory
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'factory')
-rw-r--r--factory/etc/issue3
-rw-r--r--factory/etc/nsswitch.conf16
-rw-r--r--factory/etc/pam.d/other6
-rw-r--r--factory/etc/pam.d/system-auth23
-rw-r--r--factory/templates/locale.conf.in3
-rw-r--r--factory/templates/meson.build19
-rw-r--r--factory/templates/vconsole.conf.in3
7 files changed, 73 insertions, 0 deletions
diff --git a/factory/etc/issue b/factory/etc/issue
new file mode 100644
index 0000000..101671f
--- /dev/null
+++ b/factory/etc/issue
@@ -0,0 +1,3 @@
+\S
+Kernel \r on an \m (\l)
+
diff --git a/factory/etc/nsswitch.conf b/factory/etc/nsswitch.conf
new file mode 100644
index 0000000..45a6820
--- /dev/null
+++ b/factory/etc/nsswitch.conf
@@ -0,0 +1,16 @@
+# This file is part of systemd.
+
+passwd: files systemd
+group: files [SUCCESS=merge] systemd
+shadow: files systemd
+gshadow: files systemd
+
+hosts: mymachines resolve [!UNAVAIL=return] files myhostname dns
+networks: files
+
+protocols: db files
+services: db files
+ethers: db files
+rpc: db files
+
+netgroup: nis
diff --git a/factory/etc/pam.d/other b/factory/etc/pam.d/other
new file mode 100644
index 0000000..c1f7296
--- /dev/null
+++ b/factory/etc/pam.d/other
@@ -0,0 +1,6 @@
+# This file is part of systemd.
+
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/factory/etc/pam.d/system-auth b/factory/etc/pam.d/system-auth
new file mode 100644
index 0000000..cb4e570
--- /dev/null
+++ b/factory/etc/pam.d/system-auth
@@ -0,0 +1,23 @@
+# This file is part of systemd.
+
+# You really want to adjust this to your local distribution. If you use this
+# unmodified you are not building systems safely and securely.
+
+auth sufficient pam_unix.so
+-auth sufficient pam_systemd_home.so
+auth required pam_deny.so
+
+account required pam_nologin.so
+-account sufficient pam_systemd_home.so
+account sufficient pam_unix.so
+account required pam_permit.so
+
+-password sufficient pam_systemd_home.so
+password sufficient pam_unix.so sha512 shadow try_first_pass
+password required pam_deny.so
+
+-session optional pam_keyinit.so revoke
+-session optional pam_loginuid.so
+-session optional pam_systemd_home.so
+-session optional pam_systemd.so
+session required pam_unix.so
diff --git a/factory/templates/locale.conf.in b/factory/templates/locale.conf.in
new file mode 100644
index 0000000..af93d04
--- /dev/null
+++ b/factory/templates/locale.conf.in
@@ -0,0 +1,3 @@
+# This is the fallback locale configuration provided by systemd.
+
+LANG="{{ SYSTEMD_DEFAULT_LOCALE }}"
diff --git a/factory/templates/meson.build b/factory/templates/meson.build
new file mode 100644
index 0000000..a3ba7b1
--- /dev/null
+++ b/factory/templates/meson.build
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+factory_etc_dir = factorydir / 'etc'
+
+custom_target(
+ 'locale.conf',
+ input : 'locale.conf.in',
+ output : 'locale.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)
+
+custom_target(
+ 'vconsole.conf',
+ input : 'vconsole.conf.in',
+ output : 'vconsole.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)
diff --git a/factory/templates/vconsole.conf.in b/factory/templates/vconsole.conf.in
new file mode 100644
index 0000000..f682487
--- /dev/null
+++ b/factory/templates/vconsole.conf.in
@@ -0,0 +1,3 @@
+# This is the fallback vconsole configuration provided by systemd.
+
+#KEYMAP={{ SYSTEMD_DEFAULT_KEYMAP }}