summaryrefslogtreecommitdiffstats
path: root/factory/templates/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'factory/templates/meson.build')
-rw-r--r--factory/templates/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/factory/templates/meson.build b/factory/templates/meson.build
new file mode 100644
index 0000000..a3ba7b1
--- /dev/null
+++ b/factory/templates/meson.build
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+factory_etc_dir = factorydir / 'etc'
+
+custom_target(
+ 'locale.conf',
+ input : 'locale.conf.in',
+ output : 'locale.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)
+
+custom_target(
+ 'vconsole.conf',
+ input : 'vconsole.conf.in',
+ output : 'vconsole.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)