summaryrefslogtreecommitdiffstats
path: root/factory/templates
diff options
context:
space:
mode:
Diffstat (limited to 'factory/templates')
-rw-r--r--factory/templates/locale.conf.in3
-rw-r--r--factory/templates/meson.build19
-rw-r--r--factory/templates/vconsole.conf.in3
3 files changed, 25 insertions, 0 deletions
diff --git a/factory/templates/locale.conf.in b/factory/templates/locale.conf.in
new file mode 100644
index 0000000..af93d04
--- /dev/null
+++ b/factory/templates/locale.conf.in
@@ -0,0 +1,3 @@
+# This is the fallback locale configuration provided by systemd.
+
+LANG="{{ SYSTEMD_DEFAULT_LOCALE }}"
diff --git a/factory/templates/meson.build b/factory/templates/meson.build
new file mode 100644
index 0000000..a3ba7b1
--- /dev/null
+++ b/factory/templates/meson.build
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+factory_etc_dir = factorydir / 'etc'
+
+custom_target(
+ 'locale.conf',
+ input : 'locale.conf.in',
+ output : 'locale.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)
+
+custom_target(
+ 'vconsole.conf',
+ input : 'vconsole.conf.in',
+ output : 'vconsole.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)
diff --git a/factory/templates/vconsole.conf.in b/factory/templates/vconsole.conf.in
new file mode 100644
index 0000000..f682487
--- /dev/null
+++ b/factory/templates/vconsole.conf.in
@@ -0,0 +1,3 @@
+# This is the fallback vconsole configuration provided by systemd.
+
+#KEYMAP={{ SYSTEMD_DEFAULT_KEYMAP }}