summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 05:50:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 05:50:19 +0000
commitb6a97bcbb33b667a7ee4acb2eb8e482333e95a1b (patch)
tree89830d7d7c2cd02e552447883d02800d56cdf323 /Makefile
parentReleasing progress-linux version 1.55.0+dfsg-1~progress7.99u1. (diff)
downloadublock-origin-b6a97bcbb33b667a7ee4acb2eb8e482333e95a1b.tar.xz
ublock-origin-b6a97bcbb33b667a7ee4acb2eb8e482333e95a1b.zip
Merging upstream version 1.57.0+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9c03018..194a3af 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
# https://stackoverflow.com/a/6273809
run_options := $(filter-out $@,$(MAKECMDGOALS))
-.PHONY: all clean test lint chromium opera firefox npm dig mv3 mv3-quick \
+.PHONY: all clean cleanassets test lint chromium opera firefox npm dig mv3 mv3-quick \
compare maxcost medcost mincost modifiers record wasm
sources := $(wildcard assets/* assets/*/* dist/version src/* src/*/* src/*/*/* src/*/*/*/*)
@@ -73,6 +73,8 @@ dist/build/uAssets:
clean:
rm -rf dist/build tmp/node_modules
+cleanassets:
+ rm -rf dist/build/mv3-data dist/build/uAssets
# Not real targets, just convenient for auto-completion at shell prompt
compare: