summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:24:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:24:13 +0000
commit6737040b677134121089b19e33f827ba38200085 (patch)
tree69fb6e6b50086d33d05dfc21e93cab6c8e53c7ca
parentReleasing progress-linux version 0.0~git20230113.4362b18-1~progress7.99u1. (diff)
downloadwasi-libc-6737040b677134121089b19e33f827ba38200085.tar.xz
wasi-libc-6737040b677134121089b19e33f827ba38200085.zip
Merging debian version 0.0~git20230113.4362b18-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/debian-flags.patch20
-rwxr-xr-xdebian/rules5
3 files changed, 12 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index c94484d..7fd6e40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+wasi-libc (0.0~git20230113.4362b18-2) unstable; urgency=medium
+
+ * Revert "build: enable stack protection" (Closes: #1051815)
+
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Wed, 13 Sep 2023 08:19:24 +0200
+
wasi-libc (0.0~git20230113.4362b18-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/debian-flags.patch b/debian/patches/debian-flags.patch
index d9ca6f8..b173f84 100644
--- a/debian/patches/debian-flags.patch
+++ b/debian/patches/debian-flags.patch
@@ -15,15 +15,7 @@ Index: wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -2728,6 +2727,7 @@
- #define __SIZE_MAX__ 4294967295UL
- #define __SIZE_TYPE__ long unsigned int
- #define __SIZE_WIDTH__ 32
-+#define __SSP_STRONG__ 2
- #define __STDARG_H
- #define __STDC_HOSTED__ 1
- #define __STDC_IEC_559__ 1
-@@ -3112,7 +3112,7 @@
+@@ -3112,7 +3111,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
@@ -44,15 +36,7 @@ Index: wasi-libc/expected/wasm32-wasi/predefined-macros.txt
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -2691,6 +2690,7 @@
- #define __SIZE_MAX__ 4294967295UL
- #define __SIZE_TYPE__ long unsigned int
- #define __SIZE_WIDTH__ 32
-+#define __SSP_STRONG__ 2
- #define __STDARG_H
- #define __STDC_HOSTED__ 1
- #define __STDC_IEC_559__ 1
-@@ -3073,7 +3073,7 @@
+@@ -3073,7 +3072,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
diff --git a/debian/rules b/debian/rules
index 66b53d1..081101b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,10 @@ export NM = llvm-nm-14
export AR = llvm-ar-14
export CC = clang-14
-export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fcf-protection=none
+# stack protector not yet supported, see
+# https://github.com/CraneStation/wasi-libc/issues/157
+# https://bugs.debian.org/1051815
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
%:
dh $@