summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 66b53d1..081101b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,10 @@ export NM = llvm-nm-14
export AR = llvm-ar-14
export CC = clang-14
-export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fcf-protection=none
+# stack protector not yet supported, see
+# https://github.com/CraneStation/wasi-libc/issues/157
+# https://bugs.debian.org/1051815
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
%:
dh $@