summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:08:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:11:45 +0000
commitdc032dad24fb4606d114c0c33c6be38154a123ad (patch)
treeb79ff8264825b486c3c3d8611a7999fc5542703b
parentMerging upstream version 0.0~git20240411.9e8c542. (diff)
downloadwasi-libc-dc032dad24fb4606d114c0c33c6be38154a123ad.tar.xz
wasi-libc-dc032dad24fb4606d114c0c33c6be38154a123ad.zip
Merging debian version 0.0~git20240411.9e8c542-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/disable-warning.patch2
-rw-r--r--debian/patches/dont-rebuild-install.patch37
-rw-r--r--debian/wasi-libc.install2
4 files changed, 30 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 8f7d0c2..207fbef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+wasi-libc (0.0~git20240411.9e8c542-1) experimental; urgency=medium
+
+ * new upstream version needed for rustc 1.79+ (WASI SDK 22)
+
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Mon, 24 Jun 2024 13:42:23 +0200
+
wasi-libc (0.0~git20230821.ec4566b-2~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
@@ -34,7 +40,7 @@ wasi-libc (0.0~git20230821.ec4566b-1) experimental; urgency=medium
* new upstream version needed for rustc 1.73+
* switch to LLVM 17
- -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Tue, 28 May 2024 17:07:42 +0200
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Mon, 27 May 2024 14:49:41 +0200
wasi-libc (0.0~git20230621.7018e24-2~progress7.99u1) graograman-backports; urgency=medium
diff --git a/debian/patches/disable-warning.patch b/debian/patches/disable-warning.patch
index f38b07d..3dbc593 100644
--- a/debian/patches/disable-warning.patch
+++ b/debian/patches/disable-warning.patch
@@ -6,7 +6,7 @@ Index: wasi-libc/Makefile
===================================================================
--- wasi-libc.orig/Makefile
+++ wasi-libc/Makefile
-@@ -315,6 +315,7 @@ CFLAGS += -Wall -Wextra -Werror \
+@@ -380,6 +380,7 @@ CFLAGS += -Wall -Wextra -Werror \
-Wno-missing-braces \
-Wno-ignored-pragmas \
-Wno-unused-but-set-variable \
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index d69946d..4f309c9 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -6,34 +6,39 @@ Index: wasi-libc/Makefile
===================================================================
--- wasi-libc.orig/Makefile
+++ wasi-libc/Makefile
-@@ -584,6 +584,8 @@ include_dirs:
- # Remove selected header files.
- $(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
+@@ -743,12 +743,15 @@ ifeq ($(WASI_SNAPSHOT), p2)
+ > "$(SYSROOT_INC)/__wasi_snapshot.h"
+ endif
+ touch $@
+
startup_files: include_dirs $(LIBC_BOTTOM_HALF_CRT_OBJS)
#
# Install the startup files (crt1.o etc).
-@@ -591,6 +593,8 @@ startup_files: include_dirs $(LIBC_BOTTO
+ #
mkdir -p "$(SYSROOT_LIB)" && \
cp $(LIBC_BOTTOM_HALF_CRT_OBJS) "$(SYSROOT_LIB)"
++ touch $@
+ # TODO: As of this writing, wasi_thread_start.s uses non-position-independent
+ # code, and I'm not sure how to make it position-independent. Once we've done
+@@ -768,6 +771,7 @@ endif
+ endif
+
+ libc_so: include_dirs $(LIBC_SO)
+ touch $@
-+
- libc: include_dirs \
+
+ STATIC_LIBS = \
$(SYSROOT_LIB)/libc.a \
- $(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -600,6 +604,8 @@ libc: include_dirs \
- $(SYSROOT_LIB)/libwasi-emulated-getpid.a \
- $(SYSROOT_LIB)/libwasi-emulated-signal.a
+@@ -784,6 +788,7 @@ STATIC_LIBS += \
+ endif
+ libc: include_dirs $(STATIC_LIBS)
+ touch $@
-+
+
finish: startup_files libc
#
- # Create empty placeholder libraries.
-@@ -611,6 +617,7 @@ finish: startup_files libc
+@@ -796,6 +801,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -41,10 +46,10 @@ Index: wasi-libc/Makefile
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -722,5 +729,6 @@ install: finish
- clean:
+@@ -982,5 +988,6 @@ clean:
+ $(RM) -r "$(BINDING_WORK_DIR)"
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"
+ $(RM) -f include_dirs startup_files libc finish
- .PHONY: default startup_files libc finish install include_dirs clean
+ .PHONY: default startup_files libc libc_so finish install include_dirs clean check-symbols bindings
diff --git a/debian/wasi-libc.install b/debian/wasi-libc.install
index 6868f56..e84288c 100644
--- a/debian/wasi-libc.install
+++ b/debian/wasi-libc.install
@@ -1,3 +1,3 @@
usr/share/wasm32-wasi
usr/lib/wasm32-wasi
-usr/include/* /usr/include/wasm32-wasi
+usr/include/wasm32-wasi/* /usr/include/wasm32-wasi