summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 13:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 13:54:39 +0000
commit7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb (patch)
tree07741545f80a7f29822eb571d02db8dd0349674f /debian/rules
parentAdding upstream version 0.0~git20221206.8b7148f. (diff)
downloadwasi-libc-7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb.tar.xz
wasi-libc-7f4e44f9469d8dcf6f95e07d0f5bb340f8830bfb.zip
Adding debian version 0.0~git20221206.8b7148f-1.debian/0.0_git20221206.8b7148f-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dca6423
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+include /usr/share/dpkg/buildflags.mk
+
+export NM = llvm-nm-14
+export AR = llvm-ar-14
+export CC = clang-14
+
+# stack protector not yet supported, see
+# https://github.com/CraneStation/wasi-libc/issues/157
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
+
+%:
+ dh $@
+
+.PHONY: build
+build:
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build -- finish
+
+override_dh_auto_install:
+ dh_auto_install -- INSTALL_DIR=$(CURDIR)/debian/tmp/usr