summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dca6423
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+include /usr/share/dpkg/buildflags.mk
+
+export NM = llvm-nm-14
+export AR = llvm-ar-14
+export CC = clang-14
+
+# stack protector not yet supported, see
+# https://github.com/CraneStation/wasi-libc/issues/157
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
+
+%:
+ dh $@
+
+.PHONY: build
+build:
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build -- finish
+
+override_dh_auto_install:
+ dh_auto_install -- INSTALL_DIR=$(CURDIR)/debian/tmp/usr