summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:24:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:24:13 +0000
commit6737040b677134121089b19e33f827ba38200085 (patch)
tree69fb6e6b50086d33d05dfc21e93cab6c8e53c7ca /debian/rules
parentReleasing progress-linux version 0.0~git20230113.4362b18-1~progress7.99u1. (diff)
downloadwasi-libc-6737040b677134121089b19e33f827ba38200085.tar.xz
wasi-libc-6737040b677134121089b19e33f827ba38200085.zip
Merging debian version 0.0~git20230113.4362b18-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 66b53d1..081101b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,10 @@ export NM = llvm-nm-14
export AR = llvm-ar-14
export CC = clang-14
-export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fcf-protection=none
+# stack protector not yet supported, see
+# https://github.com/CraneStation/wasi-libc/issues/157
+# https://bugs.debian.org/1051815
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
%:
dh $@