summaryrefslogtreecommitdiffstats
path: root/monitoring/ceph-mixin/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /monitoring/ceph-mixin/Makefile
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'monitoring/ceph-mixin/Makefile')
-rw-r--r--monitoring/ceph-mixin/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/monitoring/ceph-mixin/Makefile b/monitoring/ceph-mixin/Makefile
new file mode 100644
index 000000000..0cb7aa539
--- /dev/null
+++ b/monitoring/ceph-mixin/Makefile
@@ -0,0 +1,24 @@
+all: fmt generate lint test
+
+fmt:
+ ./lint-jsonnet.sh -i
+
+generate: dashboards_out
+
+vendor: jsonnetfile.lock.json
+ tox -ejsonnet-bundler-install
+
+dashboards_out: vendor dashboards
+ tox -ejsonnet-fix
+
+lint:
+ tox -ejsonnet-lint
+ tox -ealerts-lint
+
+test: generate
+ tox -ejsonnet-check
+ tox -epromql-query-test
+ tox -ealerts-check
+check: test
+
+.PHONY: all fmt generate lint test check