summaryrefslogtreecommitdiffstats
path: root/monitoring/ceph-mixin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'monitoring/ceph-mixin/Makefile')
-rw-r--r--monitoring/ceph-mixin/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/monitoring/ceph-mixin/Makefile b/monitoring/ceph-mixin/Makefile
new file mode 100644
index 000000000..0cb7aa539
--- /dev/null
+++ b/monitoring/ceph-mixin/Makefile
@@ -0,0 +1,24 @@
+all: fmt generate lint test
+
+fmt:
+ ./lint-jsonnet.sh -i
+
+generate: dashboards_out
+
+vendor: jsonnetfile.lock.json
+ tox -ejsonnet-bundler-install
+
+dashboards_out: vendor dashboards
+ tox -ejsonnet-fix
+
+lint:
+ tox -ejsonnet-lint
+ tox -ealerts-lint
+
+test: generate
+ tox -ejsonnet-check
+ tox -epromql-query-test
+ tox -ealerts-check
+check: test
+
+.PHONY: all fmt generate lint test check