summaryrefslogtreecommitdiffstats
path: root/man/deb-changes.pod
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /man/deb-changes.pod
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man/deb-changes.pod')
-rw-r--r--man/deb-changes.pod218
1 files changed, 218 insertions, 0 deletions
diff --git a/man/deb-changes.pod b/man/deb-changes.pod
new file mode 100644
index 0000000..d72ca6b
--- /dev/null
+++ b/man/deb-changes.pod
@@ -0,0 +1,218 @@
+# dpkg manual page - deb-changes(5)
+#
+# Copyright © 1995-1996 Ian Jackson <ijackson@chiark.greenend.org.uk>
+# Copyright © 2010 Russ Allbery <rra@debian.org>
+# Copyright © 2015 Guillem Jover <guillem@debian.org>
+#
+# This is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+=encoding utf8
+
+=head1 NAME
+
+deb-changes - Debian changes file format
+
+=head1 SYNOPSIS
+
+I<filename>B<.changes>
+
+=head1 DESCRIPTION
+
+Each Debian upload is composed of a .changes control file, which
+contains a number of fields in L<deb822(5)> format.
+
+Each field begins with a tag, such as
+B<Source>
+or
+B<Binary>
+(case insensitive), followed by a colon, and the body of the field
+(case sensitive unless stated otherwise).
+Fields are delimited only by field tags.
+In other words, field text may be multiple lines in length, but the
+installation tools will generally join lines when processing the body
+of the field (except in case of the multiline fields
+B<Description>, B<Changes>, B<Files>, B<Checksums-Sha1>
+and
+B<Checksums-Sha256>,
+see below).
+
+The control data might be enclosed in an OpenPGP ASCII Armored signature,
+as specified in RFC4880.
+
+=head1 FIELDS
+
+=over
+
+=item B<Format:> I<format-version> (required)
+
+The value of this field declares the format version of the file.
+The syntax of the field value is a version number with a major and minor
+component.
+Backward incompatible changes to the format will bump the major version,
+and backward compatible changes (such as field additions) will bump the
+minor version.
+The current format version is B<1.8>.
+
+=item B<Date:> I<release-date> (required)
+
+The date the package was built or last edited.
+It must be in the same format as the date in a B<deb-changelog>(5)
+entry.
+
+The value of this field is usually extracted from the I<debian/changelog>
+file.
+
+=item B<Source:> I<source-name> [B<(>I<source-version>B<)>] (required)
+
+The name of the source package.
+If the source version differs from the binary version, then the
+I<source-name> will be followed by a I<source-version> in parenthesis.
+This can happen when the upload is a binary-only non-maintainer upload.
+
+=item B<Binary:> I<binary-package-list> (required in context)
+
+This folded field is a space-separated list of binary packages to upload.
+If the upload is source-only, then the field is omitted (since dpkg 1.19.3).
+
+=item B<Architecture:> I<arch-list>
+
+Lists the architectures of the files currently being uploaded.
+Common architectures are B<amd64>, B<armel>, B<i386>, etc.
+Note that the B<all> value is meant for packages that are architecture
+independent.
+If the source for the package is also being uploaded, the special entry
+B<source> is also present.
+Architecture wildcards must never be present in the list.
+
+=item B<Version:> I<version-string> (required)
+
+Typically, this is the original package's version number in whatever form
+the program's author uses.
+It may also include a Debian revision number (for non-native packages).
+The exact format and sorting algorithm are described in
+B<deb-version>(7).
+
+=item B<Distribution:> I<distribution>s (required)
+
+Lists one or more space-separated distributions where this version should
+be installed when it is uploaded to the archive.
+
+=item B<Urgency:> I<urgency> (recommended)
+
+The urgency of the upload.
+The currently known values, in increasing order of urgency, are:
+B<low>, B<medium>, B<high>, B<critical> and B<emergency>.
+
+=item B<Maintainer:> I<fullname-email> (required)
+
+Should be in the format “Joe Bloggs E<lt>jbloggs@example.orgE<gt>”, and is
+typically the person who created the package, as opposed to the author of
+the software that was packaged.
+
+=item B<Changed-By:> I<fullname-email>
+
+Should be in the format “Joe Bloggs E<lt>jbloggs@example.orgE<gt>”, and is
+typically the person who prepared the package changes for this release.
+
+=item B<Description:> (recommended)
+
+=item S< >I<binary-package-name> B<-> I<binary-package-summary>
+
+This multiline field contains a list of binary package names followed by
+a space, a dash (‘B<->’) and their possibly truncated short
+descriptions.
+If the upload is source-only, then the field is omitted (since dpkg 1.19.3).
+
+=item B<Closes:> I<bug-number-list>
+
+A space-separated list of bug report numbers for bug reports that have been
+resolved with this upload.
+The distribution archive software might use this field to automatically
+close the referred bug numbers in the distribution bug tracking system.
+
+=item B<Binary-Only: yes>
+
+This field denotes that the upload is a binary-only non-maintainer build.
+It originates from the B<binary-only=yes> key/value from the changelog
+metadata entry.
+
+=item B<Built-For-Profiles:> I<profile-list>
+
+This field specifies a whitespace separated list of build profiles that
+this upload was built with.
+
+=item B<Changes:> (required)
+
+=item S< >I<changelog-entries>
+
+This multiline field contains the concatenated text of all changelog
+entries that are part of the upload.
+To make this a valid multiline field empty lines are replaced with a
+single full stop (‘.’) and all lines are indented by one space
+character.
+The exact content depends on the changelog format.
+
+=item B<Files:> (required)
+
+=item S< >I<md5sum> I<size> I<section> I<priority> I<filename>
+
+This multiline field contains a list of files with an md5sum, size, section
+and priority for each one.
+
+The first line of the field value (the part on the same line as the field
+name followed by a colon) is always empty.
+The content of the field is expressed as continuation lines, one line per file.
+Each line consists of space-separated entries describing the file:
+the md5sum, the file size, the file section, the file priority, and
+the file name.
+
+This field lists all files that make up the upload.
+The list of files in this field must match the list of files in the
+other related B<Checksums> fields.
+
+=item B<Checksums-Sha1:> (required)
+
+=item B<Checksums-Sha256:> (required)
+
+=item S< >I<checksum> I<size> I<filename>
+
+These multiline fields contain a list of files with a checksum and size
+for each one.
+These fields have the same syntax and differ only in the checksum algorithm
+used: SHA-1 for B<Checksums-Sha1> and SHA-256 for B<Checksums-Sha256>.
+
+The first line of the field value (the part on the same line as the field
+name followed by a colon) is always empty.
+The content of the field is expressed as continuation lines, one line per file.
+Each line consists of space-separated entries describing the file:
+the checksum, the file size, and the file name.
+
+These fields list all files that make up the upload.
+The list of files in these fields must match the list of files in the
+B<Files> field and the other related B<Checksums> fields.
+
+=back
+
+=head1 BUGS
+
+The B<Files> field is inconsistent with the other B<Checksums> fields.
+The B<Changed-By> and B<Maintainer> fields have confusing names.
+The B<Distribution> field contains information about what is commonly
+referred to as a suite.
+
+=head1 SEE ALSO
+
+L<deb822(5)>,
+B<deb-src-control>(5),
+B<deb-version>(7).