summaryrefslogtreecommitdiffstats
path: root/tests/t-normal
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-normal')
-rw-r--r--tests/t-normal/Makefile12
-rw-r--r--tests/t-normal/pkg-normal/DEBIAN/control8
2 files changed, 20 insertions, 0 deletions
diff --git a/tests/t-normal/Makefile b/tests/t-normal/Makefile
new file mode 100644
index 0000000..70e1dd0
--- /dev/null
+++ b/tests/t-normal/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-normal
+
+include ../Test.mk
+
+test-case:
+ # test normal working packages
+ $(DPKG_INSTALL) pkg-normal.deb
+ $(call pkg_is_installed,pkg-normal)
+
+test-clean:
+ $(DPKG_PURGE) pkg-normal
+
diff --git a/tests/t-normal/pkg-normal/DEBIAN/control b/tests/t-normal/pkg-normal/DEBIAN/control
new file mode 100644
index 0000000..09e51b2
--- /dev/null
+++ b/tests/t-normal/pkg-normal/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-normal
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - normal
+