summaryrefslogtreecommitdiffstats
path: root/build/rust/bindgen
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/bindgen')
-rw-r--r--build/rust/bindgen/Cargo.toml18
-rw-r--r--build/rust/bindgen/lib.rs26
2 files changed, 44 insertions, 0 deletions
diff --git a/build/rust/bindgen/Cargo.toml b/build/rust/bindgen/Cargo.toml
new file mode 100644
index 0000000000..b68e2eb6bb
--- /dev/null
+++ b/build/rust/bindgen/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "bindgen"
+version = "0.63.999"
+edition = "2018"
+license = "BSD-3-Clause"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.bindgen]
+version = "0.64.0"
+default-features = false
+
+[features]
+logging = ["bindgen/logging"]
+runtime = ["bindgen/runtime"]
+static = ["bindgen/static"]
+which-rustfmt = ["bindgen/which-rustfmt"]
diff --git a/build/rust/bindgen/lib.rs b/build/rust/bindgen/lib.rs
new file mode 100644
index 0000000000..6828a430d5
--- /dev/null
+++ b/build/rust/bindgen/lib.rs
@@ -0,0 +1,26 @@
+// Redistribution and use in source and binary forms, with or without
+// modification, are permitted provided that the following conditions are met:
+//
+// * Redistributions of source code must retain the above copyright notice, this
+// list of conditions and the following disclaimer.
+//
+// * Redistributions in binary form must reproduce the above copyright notice,
+// this list of conditions and the following disclaimer in the documentation
+// and/or other materials provided with the distribution.
+//
+// * Neither the name of the copyright holder nor the names of its
+// contributors may be used to endorse or promote products derived from
+// this software without specific prior written permission.
+//
+// THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+// AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+// IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+// DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+// FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+// DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+// SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+// CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+// OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+// OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+pub use bindgen::*;