summaryrefslogtreecommitdiffstats
path: root/third_party/rust/error-support/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/error-support/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/error-support/Cargo.toml')
-rw-r--r--third_party/rust/error-support/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/rust/error-support/Cargo.toml b/third_party/rust/error-support/Cargo.toml
new file mode 100644
index 0000000000..95c9d562f6
--- /dev/null
+++ b/third_party/rust/error-support/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "error-support"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+edition = "2021"
+license = "MPL-2.0"
+
+[dependencies]
+log = "0.4"
+lazy_static = { version = "1.4" }
+parking_lot = { version = ">=0.11,<=0.12" }
+uniffi = { version = "^0.21" }
+uniffi_macros = { version = "^0.21" }
+
+[dependencies.backtrace]
+optional = true
+version = "0.3"
+
+[build-dependencies]
+uniffi_build = { version = "^0.21", features=["builtin-bindgen"] }