summaryrefslogtreecommitdiffstats
path: root/third_party/rust/error-support/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/error-support/Cargo.toml')
-rw-r--r--third_party/rust/error-support/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/rust/error-support/Cargo.toml b/third_party/rust/error-support/Cargo.toml
new file mode 100644
index 0000000000..95c9d562f6
--- /dev/null
+++ b/third_party/rust/error-support/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "error-support"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+edition = "2021"
+license = "MPL-2.0"
+
+[dependencies]
+log = "0.4"
+lazy_static = { version = "1.4" }
+parking_lot = { version = ">=0.11,<=0.12" }
+uniffi = { version = "^0.21" }
+uniffi_macros = { version = "^0.21" }
+
+[dependencies.backtrace]
+optional = true
+version = "0.3"
+
+[build-dependencies]
+uniffi_build = { version = "^0.21", features=["builtin-bindgen"] }