summaryrefslogtreecommitdiffstats
path: root/build/rust/rand
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/rand')
-rw-r--r--build/rust/rand/Cargo.toml22
-rw-r--r--build/rust/rand/lib.rs5
2 files changed, 27 insertions, 0 deletions
diff --git a/build/rust/rand/Cargo.toml b/build/rust/rand/Cargo.toml
new file mode 100644
index 0000000000..03e7ec4843
--- /dev/null
+++ b/build/rust/rand/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "rand"
+version = "0.7.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.rand]
+version = "0.8"
+default-features = false
+
+[features]
+alloc = ["rand/alloc"]
+default = ["rand/default"]
+getrandom = ["rand/getrandom"]
+nightly = ["rand/nightly"]
+serde1 = ["rand/serde1"]
+simd_support = ["rand/simd_support"]
+small_rng = ["rand/small_rng"]
+std = ["rand/std"]
diff --git a/build/rust/rand/lib.rs b/build/rust/rand/lib.rs
new file mode 100644
index 0000000000..14be7b7d8c
--- /dev/null
+++ b/build/rust/rand/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use rand::*;