summaryrefslogtreecommitdiffstats
path: root/plugins/externaltools/tests/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 17:42:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 17:42:51 +0000
commitba429d344132c088177e853cce8ff7181570b221 (patch)
tree87ebf15269b4301737abd1735baabba71be93622 /plugins/externaltools/tests/meson.build
parentInitial commit. (diff)
downloadgedit-upstream.tar.xz
gedit-upstream.zip
Adding upstream version 44.2.upstream/44.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/externaltools/tests/meson.build')
-rw-r--r--plugins/externaltools/tests/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/externaltools/tests/meson.build b/plugins/externaltools/tests/meson.build
new file mode 100644
index 0000000..6cee9fe
--- /dev/null
+++ b/plugins/externaltools/tests/meson.build
@@ -0,0 +1,21 @@
+externaltools_tests = {
+ 'LinkParser': files('testlinkparsing.py'),
+}
+
+externaltools_srcdir = join_paths(
+ srcdir,
+ 'plugins',
+ 'externaltools',
+ 'tools',
+)
+
+foreach test_name, test_script : externaltools_tests
+ test(
+ 'test-externaltools-@0@'.format(test_name),
+ python3,
+ args: [test_script],
+ env: [
+ 'PYTHONPATH=@0@'.format(externaltools_srcdir),
+ ]
+ )
+endforeach