summaryrefslogtreecommitdiffstats
path: root/plugins/externaltools/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/externaltools/tests/meson.build')
-rw-r--r--plugins/externaltools/tests/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/externaltools/tests/meson.build b/plugins/externaltools/tests/meson.build
new file mode 100644
index 0000000..6cee9fe
--- /dev/null
+++ b/plugins/externaltools/tests/meson.build
@@ -0,0 +1,21 @@
+externaltools_tests = {
+ 'LinkParser': files('testlinkparsing.py'),
+}
+
+externaltools_srcdir = join_paths(
+ srcdir,
+ 'plugins',
+ 'externaltools',
+ 'tools',
+)
+
+foreach test_name, test_script : externaltools_tests
+ test(
+ 'test-externaltools-@0@'.format(test_name),
+ python3,
+ args: [test_script],
+ env: [
+ 'PYTHONPATH=@0@'.format(externaltools_srcdir),
+ ]
+ )
+endforeach