summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
commitdf7baa2644d541634825e28851c2bd8a47cd5233 (patch)
tree097c499ac161feb4345b18a4f6605e7199d6a635
parentInitial commit. (diff)
downloadgnome-shell-extension-impatience-upstream.tar.xz
gnome-shell-extension-impatience-upstream.zip
Adding upstream version 0.4.8.upstream/0.4.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--LICENCE15
-rw-r--r--Makefile13
-rw-r--r--README.md3
-rw-r--r--VERSION1
-rw-r--r--all.gup2
-rw-r--r--compile.gup2
-rw-r--r--gnome-shell-impatience.dist2
-rw-r--r--gnome-shell-impatience.xml56
-rw-r--r--gnome-shell-impatience.xml.template28
-rw-r--r--impatience/extension.js60
-rw-r--r--impatience/metadata.json7
-rw-r--r--impatience/prefs.js62
-rw-r--r--impatience/schemas/gschemas.compiledbin0 -> 332 bytes
-rw-r--r--impatience/schemas/org.gnome.shell.extensions.net.gfxmonk.impatience.gschema.xml10
-rw-r--r--impatience/settings.js17
-rw-r--r--schemas.gup4
l---------xdg/data/glib-2.0/schemas1
l---------xdg/data/gnome-shell/extensions/impatience@gfxmonk.net1
18 files changed, 284 insertions, 0 deletions
diff --git a/LICENCE b/LICENCE
new file mode 100644
index 0000000..234117d
--- /dev/null
+++ b/LICENCE
@@ -0,0 +1,15 @@
+Copyright (C) 2012 Tim Cuthbertson
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 3 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c921969
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+all: schemas zip
+
+0: phony
+ mkzero-gfxmonk -p impatience -p xdg gnome-shell-impatience.xml
+
+schemas: phony
+ cd impatience/schemas && glib-compile-schemas .
+
+zip: phony
+ rm -f impatience@gfxmonk.net.zip
+ cd impatience && zip -r ../impatience@gfxmonk.net.zip *
+
+.PHONY: phony
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..2561f1e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+<img src="http://gfxmonk.net/dist/status/project/gnome-shell-impatience.png">
+
+Speed up builtin gnome-shell animations.
diff --git a/VERSION b/VERSION
new file mode 100644
index 0000000..c650d5a
--- /dev/null
+++ b/VERSION
@@ -0,0 +1 @@
+0.4.8 \ No newline at end of file
diff --git a/all.gup b/all.gup
new file mode 100644
index 0000000..e0d448b
--- /dev/null
+++ b/all.gup
@@ -0,0 +1,2 @@
+#!bash -eu
+gup -u compile
diff --git a/compile.gup b/compile.gup
new file mode 100644
index 0000000..9287327
--- /dev/null
+++ b/compile.gup
@@ -0,0 +1,2 @@
+#!bash -eu
+gup -u schemas
diff --git a/gnome-shell-impatience.dist b/gnome-shell-impatience.dist
new file mode 100644
index 0000000..f96d04c
--- /dev/null
+++ b/gnome-shell-impatience.dist
@@ -0,0 +1,2 @@
+impatience
+xdg
diff --git a/gnome-shell-impatience.xml b/gnome-shell-impatience.xml
new file mode 100644
index 0000000..89c5702
--- /dev/null
+++ b/gnome-shell-impatience.xml
@@ -0,0 +1,56 @@
+<?xml version="1.0"?>
+<?xml-stylesheet type='text/xsl' href='interface.xsl'?>
+<interface xmlns="http://zero-install.sourceforge.net/2004/injector/interface" uri="http://gfxmonk.net/dist/0install/gnome-shell-impatience.xml">
+ <name>gnome-shell-impatience</name>
+ <summary>speed up gnome-shell animations</summary>
+ <publish xmlns="http://gfxmonk.net/dist/0install" mode="default"/>
+ <description>
+Speed up builtin gnome-shell animations.
+ </description>
+ <group>
+ <command name="run">
+ <runner interface="http://gfxmonk.net/dist/0install/zeroinstall-plugin-manager.xml">
+ <arg>http://gfxmonk.net/dist/0install/gnome-shell.xml</arg>
+ <arg>--plugin-command</arg>
+ <arg>run</arg>
+ </runner>
+ <requires interface="http://gfxmonk.net/dist/0install/gnome-shell.xml">
+ <version not-before="3.0.2"/>
+ </requires>
+ </command>
+ <environment insert="xdg/data" mode="prepend" name="XDG_DATA_DIRS"/>
+ <implementation id="sha1new=bb15a209852b1e6ff4b12de009fd15461f5980b4" released="2012-04-08" version="0.1">
+ <manifest-digest sha256="e10c2ab5b8fff75b6f8c1cd730d3495d04263239021ca2e61235fb3d4d906b3a"/>
+ <archive href="http://gfxmonk.net/dist/0install/gnome-shell-impatience/gnome-shell-impatience-0.1.tgz" size="1897"/>
+ </implementation>
+ <implementation id="sha1new=3b1999db5b574291bc002288adec56cc339930da" released="2012-04-09" version="0.2">
+ <manifest-digest sha256="4740de8b8cbf3e188910fca2051c18311be7a4e8c671f71859675333e906753c"/>
+ <archive href="http://gfxmonk.net/dist/0install/gnome-shell-impatience/gnome-shell-impatience-0.2.tgz" size="1861"/>
+ </implementation>
+ <implementation id="sha1new=ff95827ded5ec34cd4a099e953971ca8390e1680" released="2012-04-09" version="0.3">
+ <manifest-digest sha256="f948c715acc92c07c6a5eb7cca42ebebfa64f5aa05f016502a68f3a04a0885eb"/>
+ <archive href="http://gfxmonk.net/dist/0install/gnome-shell-impatience/gnome-shell-impatience-0.3.tgz" size="1955"/>
+ </implementation>
+ </group>
+ <group>
+ <command name="run">
+ <runner interface="http://gfxmonk.net/dist/0install/zeroinstall-plugin-manager.xml">
+ <arg>http://gfxmonk.net/dist/0install/gnome-shell.xml</arg>
+ <arg>--plugin-command</arg>
+ <arg>run</arg>
+ </runner>
+ <requires interface="http://gfxmonk.net/dist/0install/gnome-shell.xml">
+ <version not-before="3.4"/>
+ </requires>
+ </command>
+ <environment insert="xdg/data" mode="prepend" name="XDG_DATA_DIRS"/>
+ <implementation id="sha1new=78f333fddbc392633cc1856bfdc7334d1428166d" released="2012-05-06" version="0.4">
+ <manifest-digest sha256="851f0c2a3a7a624451ecfa072da568ea052f4e7ceedce42b7a228ff2dbd7cf75"/>
+ <archive href="http://gfxmonk.net/dist/0install/gnome-shell-impatience/gnome-shell-impatience-0.4.tgz" size="2338"/>
+ </implementation>
+ <implementation id="sha1new=7f9b00671675795bfffeb8a99d87df5f2bc8e3ec" released="2012-12-29" version="0.4.1">
+ <manifest-digest sha256="ab60737eb157da8fc343c4e8b52767b8ae8848c9d2bfc820b1993ef66866f1a1"/>
+ <archive href="http://gfxmonk.net/dist/0install/gnome-shell-impatience/gnome-shell-impatience-0.4.1.tgz" size="2348"/>
+ </implementation>
+ </group>
+</interface>
diff --git a/gnome-shell-impatience.xml.template b/gnome-shell-impatience.xml.template
new file mode 100644
index 0000000..540f6c7
--- /dev/null
+++ b/gnome-shell-impatience.xml.template
@@ -0,0 +1,28 @@
+<?xml version="1.0"?>
+<?xml-stylesheet type='text/xsl' href='interface.xsl'?>
+<interface xmlns="http://zero-install.sourceforge.net/2004/injector/interface">
+ <name>gnome-shell-impatience</name>
+ <summary>speed up gnome-shell animations</summary>
+ <publish xmlns="http://gfxmonk.net/dist/0install" mode="default"/>
+ <description>
+Speed up builtin gnome-shell animations.
+ </description>
+ <feed-for interface="http://gfxmonk.net/dist/0install/gnome-shell-impatience.xml"/>
+ <group>
+ <command name="run">
+ <runner interface="http://gfxmonk.net/dist/0install/zeroinstall-plugin-manager.xml">
+ <arg>http://gfxmonk.net/dist/0install/gnome-shell.xml</arg>
+ <arg>--plugin-command</arg>
+ <arg>run</arg>
+ </runner>
+ <requires interface="http://gfxmonk.net/dist/0install/gnome-shell.xml">
+ <version not-before="3.4"/>
+ </requires>
+ </command>
+ <environment insert="xdg/data" mode="prepend" name="XDG_DATA_DIRS"/>
+ <implementation version="{version}">
+ <manifest-digest/>
+ <archive href="{archive}"/>
+ </implementation>
+ </group>
+</interface>
diff --git a/impatience/extension.js b/impatience/extension.js
new file mode 100644
index 0000000..8b54d3d
--- /dev/null
+++ b/impatience/extension.js
@@ -0,0 +1,60 @@
+const St = imports.gi.St;
+const Gio = imports.gi.Gio;
+const DEFAULT_SPEED = 0.75;
+const ExtensionUtils = imports.misc.extensionUtils;
+const Extension = ExtensionUtils.getCurrentExtension();
+const Settings = Extension.imports.settings;
+
+function LOG(m){
+ global.log("[impatience] " + m);
+};
+function Ext() {
+ this._init.apply(this, arguments);
+};
+var noop = function() {};
+
+Ext.prototype = {};
+Ext.prototype._init = function() {
+ this.enabled = false;
+ this.original_speed = St.Settings.get().slow_down_factor;
+ this.modified_speed = DEFAULT_SPEED;
+ this.unbind = noop;
+};
+
+Ext.prototype.enable = function() {
+ var self = this;
+ this.enabled = true;
+ var pref = (new Settings.Prefs()).SPEED;
+ LOG("enabled");
+ var binding = pref.changed(function() {
+ self.set_speed(pref.get());
+ });
+ this.unbind = function() {
+ pref.disconnect(binding);
+ self.unbind = noop;
+ };
+ this.set_speed(pref.get());
+};
+
+Ext.prototype.disable = function() {
+ this.enabled = false;
+ this.unbind();
+ St.Settings.get().slow_down_factor = this.original_speed;
+};
+
+Ext.prototype.set_speed = function(new_speed) {
+ if(!this.enabled) {
+ LOG("NOT setting new speed, since the extension is disabled.");
+ return;
+ }
+ if(new_speed !== undefined) {
+ this.modified_speed = new_speed;
+ }
+ LOG("setting new speed: " + this.modified_speed);
+ St.Settings.get().slow_down_factor = this.modified_speed;
+};
+
+function init() {
+ return new Ext();
+};
+
diff --git a/impatience/metadata.json b/impatience/metadata.json
new file mode 100644
index 0000000..e4753df
--- /dev/null
+++ b/impatience/metadata.json
@@ -0,0 +1,7 @@
+{
+ "uuid": "impatience@gfxmonk.net",
+ "name": "Impatience",
+ "description": "Speed up the gnome-shell animation speed",
+ "url": "http://gfxmonk.net/dist/0install/gnome-shell-impatience.xml",
+ "shell-version": [ "40", "41", "42" ]
+}
diff --git a/impatience/prefs.js b/impatience/prefs.js
new file mode 100644
index 0000000..286599e
--- /dev/null
+++ b/impatience/prefs.js
@@ -0,0 +1,62 @@
+const Gtk = imports.gi.Gtk;
+
+let Extension = imports.misc.extensionUtils.getCurrentExtension();
+let Settings = Extension.imports.settings;
+
+function init() {
+}
+
+function buildPrefsWidget() {
+ let config = new Settings.Prefs();
+ let frame = new Gtk.Box({
+ orientation: Gtk.Orientation.VERTICAL,
+ 'margin-top': 20,
+ 'margin-bottom': 20,
+ 'margin-start': 20,
+ 'margin-end': 20
+ });
+
+ (function() {
+ let hbox = new Gtk.Box({
+ orientation: Gtk.Orientation.HORIZONTAL,
+ spacing: 20
+ });
+
+ let label = new Gtk.Label({
+ label: "Speed scaling\n<small>(1 = normal, 0.5 = twice as fast)</small>",
+ use_markup: true,
+ });
+ let adjustment = new Gtk.Adjustment({
+ lower: 0,
+ upper: 2,
+ step_increment: 0.05
+ });
+ let scale = new Gtk.Scale({
+ orientation: Gtk.Orientation.HORIZONTAL,
+ digits:2,
+ adjustment: adjustment,
+ hexpand: true,
+ value_pos: Gtk.PositionType.RIGHT
+ });
+
+ hbox.append(label);
+ hbox.append(scale);
+ frame.append(hbox);
+
+ var pref = config.SPEED;
+ scale.set_value(pref.get());
+ [0.25, 0.5, 1.0, 2.0].forEach(
+ mark => scale.add_mark(mark, Gtk.PositionType.TOP, "<small>" + mark + "</small>")
+ );
+ scale.connect('value-changed', function(sw) {
+ var oldval = pref.get();
+ var newval = sw.get_value();
+ if (newval != pref.get()) {
+ pref.set(newval);
+ }
+ });
+ })();
+
+ frame.show();
+ return frame;
+}
diff --git a/impatience/schemas/gschemas.compiled b/impatience/schemas/gschemas.compiled
new file mode 100644
index 0000000..8be15e0
--- /dev/null
+++ b/impatience/schemas/gschemas.compiled
Binary files differ
diff --git a/impatience/schemas/org.gnome.shell.extensions.net.gfxmonk.impatience.gschema.xml b/impatience/schemas/org.gnome.shell.extensions.net.gfxmonk.impatience.gschema.xml
new file mode 100644
index 0000000..ffd0c93
--- /dev/null
+++ b/impatience/schemas/org.gnome.shell.extensions.net.gfxmonk.impatience.gschema.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<schemalist>
+ <schema id="org.gnome.shell.extensions.net.gfxmonk.impatience" path="/org/gnome/shell/extensions/net/gfxmonk/impatience/">
+ <key type="d" name="speed-factor">
+ <default>0.75</default>
+ <summary>speed factor</summary>
+ <description/>
+ </key>
+ </schema>
+</schemalist>
diff --git a/impatience/settings.js b/impatience/settings.js
new file mode 100644
index 0000000..8d59838
--- /dev/null
+++ b/impatience/settings.js
@@ -0,0 +1,17 @@
+const Gio = imports.gi.Gio;
+const ExtensionUtils = imports.misc.extensionUtils;
+const Extension = ExtensionUtils.getCurrentExtension();
+
+const SCHEMA_PATH = 'org.gnome.shell.extensions.net.gfxmonk.impatience';
+
+function Prefs() {
+ var self = this;
+ var settings = this.settings = ExtensionUtils.getSettings(SCHEMA_PATH);
+ this.SPEED = {
+ key: 'speed-factor',
+ get: function() { return settings.get_double(this.key); },
+ set: function(v) { settings.set_double(this.key, v); },
+ changed: function(cb) { return settings.connect('changed::' + this.key, cb); },
+ disconnect: function() { return settings.disconnect.apply(settings, arguments); },
+ };
+};
diff --git a/schemas.gup b/schemas.gup
new file mode 100644
index 0000000..5cfd7a3
--- /dev/null
+++ b/schemas.gup
@@ -0,0 +1,4 @@
+#!bash -eu
+gup --always
+cd impatience/schemas
+glib-compile-schemas .
diff --git a/xdg/data/glib-2.0/schemas b/xdg/data/glib-2.0/schemas
new file mode 120000
index 0000000..80200e5
--- /dev/null
+++ b/xdg/data/glib-2.0/schemas
@@ -0,0 +1 @@
+../../../impatience/schemas \ No newline at end of file
diff --git a/xdg/data/gnome-shell/extensions/impatience@gfxmonk.net b/xdg/data/gnome-shell/extensions/impatience@gfxmonk.net
new file mode 120000
index 0000000..e3fde42
--- /dev/null
+++ b/xdg/data/gnome-shell/extensions/impatience@gfxmonk.net
@@ -0,0 +1 @@
+../../../../impatience \ No newline at end of file