summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
commit520adbc916fa3f0981282af30dbff312f15e8a0e (patch)
tree77154562ebd903f978c9d7b63516610090b8fb83 /debian/rules
parentAdding upstream version 0.4.8. (diff)
downloadgnome-shell-extension-impatience-debian.tar.xz
gnome-shell-extension-impatience-debian.zip
Adding debian version 0.4.8-2.debian/0.4.8-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7c82b30
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+# We don't need to build a zip archive, and skipping it
+# reduces the need for zip as a build-dep.
+# We do need to compile new plugin schemas though since the
+# schema path is hardcoded for this plugin.
+override_dh_auto_build:
+ glib-compile-schemas --strict --targetdir=impatience/schemas/ impatience/schemas