summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7c82b30
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+# We don't need to build a zip archive, and skipping it
+# reduces the need for zip as a build-dep.
+# We do need to compile new plugin schemas though since the
+# schema path is hardcoded for this plugin.
+override_dh_auto_build:
+ glib-compile-schemas --strict --targetdir=impatience/schemas/ impatience/schemas