summaryrefslogtreecommitdiffstats
path: root/share/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
commitcca66b9ec4e494c1d919bff0f71a820d8afab1fa (patch)
tree146f39ded1c938019e1ed42d30923c2ac9e86789 /share/doc/CMakeLists.txt
parentInitial commit. (diff)
downloadinkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.tar.xz
inkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'share/doc/CMakeLists.txt')
-rw-r--r--share/doc/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/share/doc/CMakeLists.txt b/share/doc/CMakeLists.txt
new file mode 100644
index 0000000..fbf83e7
--- /dev/null
+++ b/share/doc/CMakeLists.txt
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+# "human-readable" LICENSE file for about dialog
+install(FILES
+ LICENSE
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)
+
+# actual LICENSE files from LICENSES subdirectory
+install(DIRECTORY
+ ${CMAKE_SOURCE_DIR}/LICENSES/
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)
+
+# additional copyright related files from root dir
+install(FILES
+ ${CMAKE_SOURCE_DIR}/AUTHORS
+ ${CMAKE_SOURCE_DIR}/TRANSLATORS
+ ${CMAKE_SOURCE_DIR}/COPYING
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)