summaryrefslogtreecommitdiffstats
path: root/share/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'share/doc/CMakeLists.txt')
-rw-r--r--share/doc/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/share/doc/CMakeLists.txt b/share/doc/CMakeLists.txt
new file mode 100644
index 0000000..fbf83e7
--- /dev/null
+++ b/share/doc/CMakeLists.txt
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+# "human-readable" LICENSE file for about dialog
+install(FILES
+ LICENSE
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)
+
+# actual LICENSE files from LICENSES subdirectory
+install(DIRECTORY
+ ${CMAKE_SOURCE_DIR}/LICENSES/
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)
+
+# additional copyright related files from root dir
+install(FILES
+ ${CMAKE_SOURCE_DIR}/AUTHORS
+ ${CMAKE_SOURCE_DIR}/TRANSLATORS
+ ${CMAKE_SOURCE_DIR}/COPYING
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/doc)