summaryrefslogtreecommitdiffstats
path: root/python/setup.py.in
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py.in')
-rw-r--r--python/setup.py.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/python/setup.py.in b/python/setup.py.in
new file mode 100644
index 0000000..bd340ba
--- /dev/null
+++ b/python/setup.py.in
@@ -0,0 +1,30 @@
+import pathlib
+import setuptools
+
+p = pathlib.Path("README.md")
+if p.exists():
+ long_description = p.read_text()
+
+setuptools.setup(
+ name='libknot',
+ version='@PACKAGE_VERSION@',
+ description='Python bindings for libknot',
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ author='Daniel Salzman',
+ author_email='daniel.salzman@nic.cz',
+ url='https://gitlab.nic.cz/knot/knot-dns',
+ license='GPL-3.0',
+ packages=['libknot'],
+ classifiers=[ # See https://pypi.org/classifiers
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Internet :: Name Service (DNS)',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Systems Administration',
+ ],
+ python_requires='>=3.5',
+)